This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 434090 - ruby-bdb failed massrebuild attempt for GCC 4.3
ruby-bdb failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ruby-bdb (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Rice
Fedora Extras Quality Assurance
:
: 440882 (view as bug list)
Depends On:
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 08:04 EST by Jesse Keating
Modified: 2013-01-09 21:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-17 10:53:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-02-22 08:04:09 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=438716
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Tyler Owen 2008-02-24 13:28:03 EST
errors in x86_64 build.log:
gcc -I. -I. -I/usr/lib64/ruby/1.8/x86_64-linux -I. -DHAVE_RB_BLOCK_PROC
-I/usr/include  -fPIC -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -Wall  -fPIC
-DHAVE_RB_ARY_INSERT -DHAVE_RB_ARY_VALUES_AT  -c log.c
env.c: In function 'bdb_env_rep_elect':
env.c:108: warning: passing argument 4 of 'envst->envp->rep_elect' makes integer
from pointer without a cast
env.c:108: error: too many arguments to function 'envst->envp->rep_elect'
env.c: In function 'bdb_env_i_conf':
env.c:1696: warning: passing argument 2 of 'envst->envp->rep_get_priority' from
incompatible pointer type
env.c:1700: warning: passing argument 2 of 'envst->envp->rep_get_nsites' from
incompatible pointer type
env.c: In function 'bdb_env_rep_get_timeout':
env.c:2073: warning: pointer targets in passing argument 3 of
'envst->envp->rep_get_timeout' differ in signedness
gcc -I. -I. -I/usr/lib64/ruby/1.8/x86_64-linux -I. -DHAVE_RB_BLOCK_PROC
-I/usr/include  -fPIC -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -Wall  -fPIC
-DHAVE_RB_ARY_INSERT -DHAVE_RB_ARY_VALUES_AT  -c recnum.c
gcc -I. -I. -I/usr/lib64/ruby/1.8/x86_64-linux -I. -DHAVE_RB_BLOCK_PROC
-I/usr/include  -fPIC -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -Wall  -fPIC
-DHAVE_RB_ARY_INSERT -DHAVE_RB_ARY_VALUES_AT  -c sequence.c
make[1]: *** [env.o] Error 1
make[1]: *** Waiting for unfinished jobs....
common.c:2137: warning: 'bdb_has_both_internal' defined but not used
make[1]: Leaving directory `/builddir/build/BUILD/bdb-0.6.0/src'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.25940 (%build)
Comment 2 Bug Zapper 2008-05-14 01:25:40 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Matt Domsch 2008-07-03 12:03:58 EDT
*** Bug 440882 has been marked as a duplicate of this bug. ***
Comment 4 FTBFS 2008-09-05 12:26:35 EDT
This package has Failed to Build From Source for many months.  Per
http://fedoraproject.org/wiki/FTBFS, this package is now proposed for
removal from the distribution.  Please address this FTBFS bug
immediately, or this package will be removed from the distribution
within the next few weeks.

Thank you for your continued contributions to Fedora, and your
commitment to ensuring Fedora packages remain buildable from source
code.
Comment 5 Matt Domsch 2008-09-17 10:53:42 EDT
built in rawhide.
http://koji.fedoraproject.org/koji/taskinfo?taskID=830274

Note You need to log in before you can comment on or make changes to this bug.