Bug 434141 - clearsilver failed massrebuild attempt for GCC 4.3
clearsilver failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: clearsilver (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey C. Ollie
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 08:09 EST by Jesse Keating
Modified: 2013-01-09 21:57 EST (History)
5 users (show)

See Also:
Fixed In Version: 0.10.5-4.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-14 13:36:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for option 1 (538 bytes, patch)
2008-04-14 12:57 EDT, Kevin Kofler
no flags Details | Diff
Patch for option 2 (714 bytes, patch)
2008-04-14 12:57 EDT, Kevin Kofler
no flags Details | Diff
Patch for option 3 (540 bytes, patch)
2008-04-14 12:57 EDT, Kevin Kofler
no flags Details | Diff

  None (edit)
Description Jesse Keating 2008-02-22 08:09:40 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=439908
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Tyler Owen 2008-02-26 07:08:24 EST
Errors in x86_64 Build.log

Processing files: clearsilver-0.10.5-2.fc9
error: File not found: /var/tmp/clearsilver-0.10.5-2.fc9-root-mockbuild/usr/bin/cs
error: File not found:
/var/tmp/clearsilver-0.10.5-2.fc9-root-mockbuild/usr/bin/cstest
Comment 2 Tom "spot" Callaway 2008-03-07 16:24:47 EST
Clearsilver is very unhappy. -O0 and -O2 -fno-strict-aliasing do not make a
difference. Using gcc 3.4 doesn't resolve the issue. 
Comment 3 Alex Lancaster 2008-03-23 08:22:17 EDT
Tried another build of clearsilver, but it still failed:

http://koji.fedoraproject.org/koji/taskinfo?taskID=527088

Proximate cause was missing files:

RPM build errors:
    File not found: /var/tmp/clearsilver-0.10.5-3.fc9-root-mockbuild/usr/bin/cs
    File not found: /var/tmp/clearsilver-0.10.5-3.fc9-root-mockbuild/usr/bin/cstest

Efficient cause appears to be that the cs and cstest binaries fail their
regression tests and (I guess) refuse to be installed:

Running cs regression tests
Failed Regression Test: test_crc.cs
  See test_crc.cs.out and test_crc.cs.err
make[1]: *** [test] Error 1
Comment 4 Kevin Kofler 2008-04-14 12:53:57 EDT
The test_crc.cs test fails on 64-bit machines because:
* ne_crc in util/neo_misc.c computes and UINT32
* _builtin_str_crc in cs/csparse.c stuffs this into a long int
* the testcase expects the UINT32 to be changed into a negative number by this 
conversion

There are 3 possible fixes:
* disable the regression tests in cs/Makefile
* patch the test_crc.cs testcase to remove the offending test
* patch _builtin_str_crc to cast the number to int

We need a fix ASAP because this failure is causing broken deps.
Comment 5 Kevin Kofler 2008-04-14 12:57:20 EDT
Created attachment 302362 [details]
Patch for option 1
Comment 6 Kevin Kofler 2008-04-14 12:57:30 EDT
Created attachment 302364 [details]
Patch for option 2
Comment 7 Kevin Kofler 2008-04-14 12:57:45 EDT
Created attachment 302365 [details]
Patch for option 3

Pick one. :-)
Comment 8 Kevin Kofler 2008-04-14 13:30:50 EDT
If I don't get any other directions, I'll pick the second option ("patch the 
test_crc.cs testcase to remove the offending test"), which I consider the least 
invasive.
Comment 9 Jeffrey C. Ollie 2008-04-14 13:36:41 EDT
Yay! It builds now:

http://koji.fedoraproject.org/koji/taskinfo?taskID=565495
Comment 10 Kevin Kofler 2008-04-14 14:35:04 EDT
Have you requested f9-final tagging from rel-eng already?
Comment 11 Jeffrey C. Ollie 2008-04-14 14:55:25 EDT
(In reply to comment #10)
> Have you requested f9-final tagging from rel-eng already?

Yes.
Comment 12 Alex Lancaster 2008-04-16 06:36:38 EDT
(In reply to comment #11)
> (In reply to comment #10)
> > Have you requested f9-final tagging from rel-eng already?
> 
> Yes.

Hmm, looking at:

http://koji.fedoraproject.org/mash/rawhide-20080416/logs/depcheck 

still shows:

Broken deps for i386
---------------------------------------------------------- 
 perl-clearsilver-0.10.4-5.fc8.i386 requires perl(:MODULE_COMPAT_5.8.8)

and noting that the build:

http://koji.fedoraproject.org/koji/buildinfo?buildID=46178

still doesn't have the f9-final tag, it looks like rel-eng either haven't tagged
it yet, or somehow missed the e-mail.  I'll send another e-mail just to be sure.

Note You need to log in before you can comment on or make changes to this bug.