Bug 434146 - xend, xenstored are consuming too much CPU
xend, xenstored are consuming too much CPU
Status: CLOSED DUPLICATE of bug 446089
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-22 08:10 EST by monbernard
Modified: 2009-12-14 16:25 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-11 10:00:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description monbernard 2008-02-22 08:10:11 EST
Description of problem: xend, xenstored are consuming too much CPU


Version-Release number of selected component (if applicable): RHEL5.1
xen-libs-3.0.3-41.el5
kernel-xen-2.6.18-53.el5
kernel-xen-devel-2.6.18-53.el5
xen-3.0.3-41.el5


How reproducible:
just loop on "xm list" command leads xend and xenstored to use a lot of CPU time

Steps to Reproduce:
1. execute the following command:
 while true; do xm list; usleep 5000;done
 
Actual results:
top command displays xend and xenstored consuming more than 50% of CPU time.

Expected results:


Additional info:
strace()'ing the xenstored process gives:

# strace -p 2647 -e trace=open,rename,unlink
Process 2647 attached - interrupt to quit
open("/var/lib/xenstored/tdb.0x6000000000027040", O_WRONLY|O_CREAT|O_TRUNC,
0640) = 1
open("/var/lib/xenstored/tdb.0x6000000000027040", O_RDWR) = 18
rename("/var/lib/xenstored/tdb.0x6000000000027040", "/var/lib/xenstored/tdb") = 0
unlink("/var/lib/xenstored/tdb.0x6000000000027040") = -1 ENOENT (No such file or
directory)
...
repeated 16 times per listed domain!
Comment 1 Daniel Berrange 2008-07-11 10:00:18 EDT

*** This bug has been marked as a duplicate of 446089 ***

Note You need to log in before you can comment on or make changes to this bug.