Bug 434157 - Panic while loading iscsi_ibft.ko (kernel-2.6.18-83.el5)
Panic while loading iscsi_ibft.ko (kernel-2.6.18-83.el5)
Status: CLOSED DUPLICATE of bug 430297
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
All Linux
low Severity medium
: rc
: ---
Assigned To: Mike Christie
Martin Jenner
:
Depends On:
Blocks: 307761
  Show dependency treegraph
 
Reported: 2008-02-22 09:47 EST by James Laska
Modified: 2013-09-02 02:24 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-25 15:45:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
boot.log (12.23 KB, text/plain)
2008-02-22 09:47 EST, James Laska
no flags Details

  None (edit)
Description James Laska 2008-02-22 09:47:39 EST
Description of problem:

Attempting to boot installer system with iBFT iSCSI adapter causing panic. 
Alternatively, attempting to load the ibft kernel module causes a panic.

# modprobe -a iscsi_ibft
general protection fault: 0000 [1] SMP
last sysfs file: /devices/pci0000:00/0000:00:1c.4/0000:06:00.0/irq
CPU 1
Modules linked in: iscsi_ibft ipv6 xfrm_nalgo crypto_api autofs4 hidp rfcomm
l2cap bluetooth sunrpc cpufreq_ondemand dm_multipath video sbs backlight i2c_ec
button batteryd
Pid: 6451, comm: modprobe Tainted: G   M  2.6.18-83.el5 #1
RIP: 0010:[<ffffffff8001a07b>]  [<ffffffff8001a07b>] vsnprintf+0x568/0x59e
RSP: 0018:ffff8100121ddda8  EFLAGS: 00010206
RAX: 78323025000a6425 RBX: ffff8100121dddf8 RCX: ffff8100121dddf8
RDX: 78323025000a6425 RSI: 0000000000000014 RDI: ffff8100149245d8
RBP: ffff8100149245d8 R08: ffff8100121dc000 R09: 000055556303a96f
R10: 800000001293f065 R11: ffff81001f409000 R12: ffff8100149245c0
R13: ffff8100149245d0 R14: ffff810001228c00 R15: ffff8100149245ec
FS:  00002aaaaaabd240(0000) GS:ffff81001f62e7c0(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
CR2: 000055556303a718 CR3: 0000000010e76000 CR4: 00000000000006e0
Process modprobe (pid: 6451, threadinfo ffff8100121dc000, task ffff81001de500c0)
Stack:  0000000000000014 ffff8100149245d8 78323025000a6425 ffff8100149245d8
 ffff8100149245d8 ffff8100149245c0 ffff8100149245d0 ffff810001228c00
 78323025000a6425 ffffffff80143642 0000003000000010 ffff8100121ddf08
Call Trace:
 [<ffffffff80143642>] kobject_set_name+0x6b/0x107
 [<ffffffff8008c1ef>] __cond_resched+0x1c/0x44
 [<ffffffff881ae20b>] :iscsi_ibft:ibft_init+0x187/0x596
 [<ffffffff800a3ce1>] sys_init_module+0xaf/0x1e8
 [<ffffffff8005d28d>] tracesys+0xd5/0xe0


Code: 8a 00 84 c0 0f 85 27 fb ff ff 48 83 3c 24 00 74 10 4c 39 fd 
RIP  [<ffffffff8001a07b>] vsnprintf+0x568/0x59e
 RSP <ffff8100121ddda8>
 <0>Kernel panic - not syncing: Fatal exception

Version-Release number of selected component (if applicable):

kernel-2.6.18-83.el5.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Boot the subject kernel 
2. Load the iscsi_ibft module 
3.
  
Actual results:
kernel panic (see above)

Expected results:
No panic

Additional info:
- This defect appears to block verification of the RHEL5.2 iBFT iSCSI support
(bug#307761).
Comment 1 James Laska 2008-02-22 09:47:39 EST
Created attachment 295635 [details]
boot.log
Comment 2 Ed Pollard 2008-02-25 11:22:52 EST
Konrad had posted another patch to bugzilla 430297 and the rhkernel mailing
list. I don't think it has been picked up yet, any chance this could be
partially to blame?

Comment 3 Ed Pollard 2008-02-25 11:28:40 EST
James,
   Can you see if the NIC was configured prior to the module being loaded? I don't
see a stack trace to compare but bugzilla 430297 details a possible panic if the
NIC is either not configured yet or misconfigured. I don't believe the patch for
this has been included yet.
Comment 4 Ed Pollard 2008-02-25 11:40:32 EST
I am going to build a kernel with the
https://bugzilla.redhat.com/show_bug.cgi?id=430297 patch on top of .83 (assuming
that it isn't already included, which i will know more about once I have the src
rpm down) and see if that resolves the issue.
Comment 5 Doug Ledford 2008-02-25 12:24:03 EST
This is an iSCSI issue, so I reassigned to Mike.
Comment 6 Konrad Rzeszutek 2008-02-25 14:00:48 EST
The patch I posted on RHKL on Feb 20th will fix this problem. The error (panic) is exactly the same we had when using Intel NICs with busted iBFT blob and the patch posted has the fix for it.  
Comment 7 James Laska 2008-02-25 15:42:03 EST
Testing against http://brewweb.devel.redhat.com/brew/taskinfo?taskID=1182589
(kernel-2.6.18-83_edp_iscsi_ibft.el5) shows that the system does *not* panic
when attempting to load the iscsi_ibft module.

[root@test154 ~]# uname -r
2.6.18-83_edp_iscsi_ibft.el5

[root@test154 ~]# lsmod  | grep iscsi
[root@test154 ~]# modprobe -a iscsi_ibft
iBFT has incorrect checksum (0xf4)!


[root@test154 ~]# dmesg | tail
iBFT detected at 0xcb3d0.
iBFT has incorrect checksum (0xf4)!

Comment 8 Ed Pollard 2008-02-25 15:45:26 EST

*** This bug has been marked as a duplicate of 430297 ***
Comment 9 Konrad Rzeszutek Wilk 2008-02-25 16:35:13 EST
James,

Thanks for testing the patch.

Note You need to log in before you can comment on or make changes to this bug.