Bug 434161 - iptables fails to load xt_iprange with kernel 2.6.25
iptables fails to load xt_iprange with kernel 2.6.25
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: iptables (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
: 449634 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-22 10:02 EST by Benny Amorsen
Modified: 2008-07-09 17:48 EDT (History)
1 user (show)

See Also:
Fixed In Version: iptables-1.4.0-4.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-03 08:09:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benny Amorsen 2008-02-22 10:02:42 EST
Description of problem:
Upgrading a current Fedora 8 install with kernel-2.6.25 from Rawhide means that
certain firewall rules fail to install. ipt_iprange has been replaced by
xt_iprange, and iptables does not know how to load that automatically.

Version-Release number of selected component (if applicable):
kernel-2.6.25-0.64.rc2.git5.fc9
iptables-1.3.8-6.fc9

How reproducible:
Every time

Steps to Reproduce:
iptables -A FORWARD -m iprange --src-range 172.31.0.12-172.31.0.13 -j ACCEPT
  
Actual results:
iptables: No chain/target/match by that name
Comment 1 Bug Zapper 2008-05-14 01:27:32 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Thomas Woerner 2008-07-01 06:16:36 EDT
*** Bug 449634 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2008-07-01 06:18:53 EDT
iptables-1.4.1.1-1.fc9 has been submitted as an update for Fedora 9
Comment 4 Fedora Update System 2008-07-02 02:33:17 EDT
iptables-1.4.1.1-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update iptables'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5960
Comment 5 Benny Amorsen 2008-07-03 08:09:18 EDT
It looks like even iptables-1.4.0-4.fc9 fixes the problem. Thanks for fixing it!
Comment 6 Fedora Update System 2008-07-09 17:48:13 EDT
iptables-1.4.1.1-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.