Bug 434162 - RHEL4 contains newer version of lvm2 than RHEL5, missing bugfixes.
RHEL4 contains newer version of lvm2 than RHEL5, missing bugfixes.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2 (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: LVM and device-mapper development team
Corey Marthaler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-22 10:16 EST by Jim Perrin
Modified: 2010-01-11 22:53 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-08 17:07:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Perrin 2008-02-22 10:16:51 EST
Description of problem:
RHEL 4 has a newer version of lvm2 than RHEL5 does. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RHEL4
2. Install RHEL5
3. rpm -q --changelog lvm2 on both.
  
Actual results:
lvm2-2.02.27-2.el4_6.2.i386.rpm
2008-01-08 22:00:00
Milan Broz <mbroz@redhat.com> - 2.02.27-2.el4_6.2:
- Fix a segfault if using pvs with --all argument.
- Fix vgreduce PV list processing not to process every PV in the VG.
Resolves: #427382

2007-11-26 22:00:00
Milan Broz <mbroz@redhat.com> - 2.02.27-2.el4_6.1:
- Fix vg_read() locking in commands such as 'vgs -o +pv_name'.
Resolves: #386841

lvm2-2.02.26-3.el5.i386.rpm
2007-08-09 22:00:00
Milan Broz <mbroz@redhat.com> - 2.02.26-3:
- Fix loading of persistent cache if cache_dir is used.
Resolves: #246516



Expected results:
RHEL5 should be at an equal or newer version to help with upgrades, and to keep
the bugfixes in order across releases. 

Additional info:
Comment 3 Jim Perrin 2008-04-09 15:03:18 EDT
hmm, no updates to this one yet?
Comment 4 Dave Wysochanski 2008-04-10 10:37:00 EDT
Sorry - should have updated this earlier.  This problem will occur approximately
 half of the time because of how the RHEL updates are done.  Currently each RHEL
update is rebased from an upstream LVM2 version to pick up as many fixes as
possible.  Also, RHEL4 and RHEL5 updates come out at different times; thus, it
might be the case that the most recent update of RHEL4 is newer than the update
of RHEL5.  Once the newer RHEL5 update comes out though (in this case 5.2), this
problem will not occur.

I'm not saying that there is not a problem with upgrades during this window of
time but just explaining the current process and its benefits (more bugfixes).
Comment 5 Jim Perrin 2008-04-10 10:44:44 EDT
Right. I don't consider this a bug in the strictest sense of the term. I see it
more as a gotcha for in-place upgrades between major versions (not supported I
know, but it is possible). 
Comment 6 Dave Wysochanski 2009-12-08 17:07:15 EST
There are no plans to change the current scheme.

Note You need to log in before you can comment on or make changes to this bug.