Bug 434164 - Package remctl-perl-2.11-4.el5 is broken / RPM remctl is not mp safe
Summary: Package remctl-perl-2.11-4.el5 is broken / RPM remctl is not mp safe
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: remctl   
(Show other bugs)
Version: el5
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Simon Wilkinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-22 15:26 UTC by Ian Durkacz
Modified: 2008-04-04 10:20 UTC (History)
0 users

Fixed In Version: 2.11-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 10:20:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ian Durkacz 2008-02-22 15:26:04 UTC
Description of problem:

Package remctl-perl-2.11-4.el5 installs okay, but an attempt to use Net::Remctl
results in the error:

  symbol lookup error:  
/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/Net/Remctl/Remctl.so:
undefined symbol: remctl

Version-Release number of selected component (if applicable):

2.11-4.el5

How reproducible:

Consistent failure.

Steps to Reproduce:
1. A simple test case is:

#!/usr/bin/perl
use Net::Remctl;
my $result = remctl("anyhost", undef, undef, "test", "echo", "Hi");
if ($result->error) {
  die "test echo failed with error ", $result->error, "\n";
} else {
  warn $result->stderr;
  print $result->stdout;
  exit $result->status;
}

2.
3.
  
Actual results:

As above:

/usr/bin/perl: symbol lookup error:
/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/Net/Remctl/Remctl.so:
undefined symbol: remctl

Expected results:


Additional info:

The problem seems to be caused by the use of the %{?_smp_mflags} macro in the
call to make in the spec file of RPM remctl-2.11-4.el5. On an SMP build machine,
the make then proceeds in the wrong order and the Perl package is built
incorrectly owing to missing dependencies.

Comment 1 Simon Wilkinson 2008-04-04 10:20:46 UTC
This is fixed by 2.11-5 on EPEL-5




Note You need to log in before you can comment on or make changes to this bug.