Bug 434267 - trousers failed massrebuild attempt for GCC 4.3
trousers failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: trousers (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Emily Ratliff
Fedora Extras Quality Assurance
:
: 440733 (view as bug list)
Depends On:
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 10:54 EST by Jesse Keating
Modified: 2013-01-09 22:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-08 00:41:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to correct INT_MAX undeclared error (1.27 KB, patch)
2008-03-01 18:37 EST, Debora Velarde
no flags Details | Diff

  None (edit)
Description Jesse Keating 2008-02-22 10:54:15 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=441438
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Kent Yoder 2008-02-22 17:40:14 EST
Reassigning bug to new maintainer, Debora Velarde.
Comment 2 Jon Stanley 2008-02-28 12:37:00 EST
resubmitted as 475917
Comment 3 Jon Stanley 2008-02-28 18:05:12 EST
crypto/openssl/symmetric.c: In function 'Trspi_SymEncrypt':
crypto/openssl/symmetric.c:262: error: 'INT_MAX' undeclared (first use in this
function)
crypto/openssl/symmetric.c:262: error: (Each undeclared identifier is reported
only once
crypto/openssl/symmetric.c:262: error: for each function it appears in.)
crypto/openssl/symmetric.c: In function 'Trspi_SymDecrypt':
crypto/openssl/symmetric.c:336: error: 'INT_MAX' undeclared (first use in this
function)
make[2]: *** [libtrousers_la-symmetric.lo] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/builddir/build/BUILD/trousers-0.3.1/src/trspi'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/trousers-0.3.1/src'
make: *** [all-recursive] Error 1
Comment 4 Debora Velarde 2008-03-01 18:37:31 EST
Created attachment 296460 [details]
patch to correct INT_MAX undeclared error

Attached patch adds #include <limits.h> to some files in the trousers package.
Comment 5 Bug Zapper 2008-05-14 01:27:39 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Emily Ratliff 2008-06-03 17:09:40 EDT
*** Bug 440733 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2008-06-04 12:31:53 EDT
trousers-0.3.1-8.fc9 has been submitted as an update for Fedora 9
Comment 8 Fedora Update System 2008-06-06 03:45:03 EDT
trousers-0.3.1-8.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update trousers'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4970
Comment 9 Matt Domsch 2008-07-08 00:41:25 EDT
builds as of 2008-07-03, version 0.3.1-8.fc10.
Comment 10 Fedora Update System 2008-07-30 16:09:08 EDT
trousers-0.3.1-8.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.