Bug 434278 - g-wrap failed massrebuild attempt for GCC 4.3
g-wrap failed massrebuild attempt for GCC 4.3
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: g-wrap (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xavier Lamien
Fedora Extras Quality Assurance
: Reopened
: 440760 (view as bug list)
Depends On:
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 10:55 EST by Jesse Keating
Modified: 2013-01-09 22:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-06 09:38:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-02-22 10:55:24 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=441625
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Jon Stanley 2008-02-28 18:11:20 EST
scratch build 477176
Comment 2 Jon Stanley 2008-02-28 18:19:57 EST
.libs/guile-wct.o: In function `scm_array_handle_ref':
/usr/include/libguile/inline.h:220: multiple definition of `scm_array_handle_ref'
.libs/guile-runtime.o:/usr/include/libguile/inline.h:220: first defined here
.libs/guile-wct.o: In function `scm_array_handle_set':
/usr/include/libguile/inline.h:235: multiple definition of `scm_array_handle_set'
.libs/guile-runtime.o:/usr/include/libguile/inline.h:235: first defined here
.libs/guile-wct.o: In function `scm_is_pair':
/usr/include/libguile/inline.h:250: multiple definition of `scm_is_pair'
.libs/guile-runtime.o:/usr/include/libguile/inline.h:250: first defined here
.libs/guile-wct.o: In function `scm_double_cell':
/usr/include/libguile/inline.h:146: multiple definition of `scm_double_cell'
.libs/guile-runtime.o:/usr/include/libguile/inline.h:146: first defined here
.libs/guile-wct.o: In function `scm_cell':
/usr/include/libguile/inline.h:69: multiple definition of `scm_cell'
.libs/guile-runtime.o:/usr/include/libguile/inline.h:69: first defined here
.libs/guile-compatibility.o: In function `scm_array_handle_ref':
/usr/include/libguile/inline.h:220: multiple definition of `scm_array_handle_ref'
.libs/guile-runtime.o:/usr/include/libguile/inline.h:220: first defined here
.libs/guile-compatibility.o: In function `scm_array_handle_set':
/usr/include/libguile/inline.h:235: multiple definition of `scm_array_handle_set'
.libs/guile-runtime.o:/usr/include/libguile/inline.h:235: first defined here
.libs/guile-compatibility.o: In function `scm_is_pair':
/usr/include/libguile/inline.h:250: multiple definition of `scm_is_pair'
.libs/guile-runtime.o:/usr/include/libguile/inline.h:250: first defined here
.libs/guile-compatibility.o: In function `scm_double_cell':
/usr/include/libguile/inline.h:146: multiple definition of `scm_double_cell'
.libs/guile-runtime.o:/usr/include/libguile/inline.h:146: first defined here
.libs/guile-compatibility.o: In function `scm_cell':
/usr/include/libguile/inline.h:69: multiple definition of `scm_cell'
.libs/guile-runtime.o:/usr/include/libguile/inline.h:69: first defined here
collect2: ld returned 1 exit status
make[4]: *** [libgwrap-guile-runtime.la] Error 1
make[4]: Leaving directory `/builddir/build/BUILD/g-wrap-1.9.9/guile/g-wrap'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/builddir/build/BUILD/g-wrap-1.9.9/guile/g-wrap'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/builddir/build/BUILD/g-wrap-1.9.9/guile'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/g-wrap-1.9.9'
make: *** [all] Error 2
Comment 3 Bug Zapper 2008-05-14 01:27:46 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Matt Domsch 2008-07-03 13:34:41 EDT
*** Bug 440760 has been marked as a duplicate of this bug. ***
Comment 5 Matt Domsch 2008-07-08 00:36:02 EDT
builds as of 2008-07-03, version 1.9.9-5.fc10.
Comment 6 Matt Domsch 2008-07-08 10:26:39 EDT
Xavier Lamien, please rebuild in koji and close.
Comment 7 FTBFS 2008-09-05 12:11:55 EDT
This package has Failed to Build From Source for many months.  Per
http://fedoraproject.org/wiki/FTBFS, this package is now proposed for
removal from the distribution.  Please address this FTBFS bug
immediately, or this package will be removed from the distribution
within the next few weeks.

Thank you for your continued contributions to Fedora, and your
commitment to ensuring Fedora packages remain buildable from source
code.
Comment 8 Xavier Lamien 2008-09-06 09:37:54 EDT
rebuilt fine now.

Note You need to log in before you can comment on or make changes to this bug.