Bug 434310 - dmraid failed massrebuild attempt for GCC 4.3
dmraid failed massrebuild attempt for GCC 4.3
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dmraid (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
Fedora Extras Quality Assurance
:
: 449569 (view as bug list)
Depends On:
Blocks: gcc43rebuildfail
  Show dependency treegraph
 
Reported: 2008-02-22 10:58 EST by Jesse Keating
Modified: 2013-01-09 22:05 EST (History)
9 users (show)

See Also:
Fixed In Version: 1.0.0.rc14-8.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-18 04:06:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-02-22 10:58:00 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=441924
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Jon Stanley 2008-02-28 19:54:49 EST
linker error

gcc -o dmraid dmraid.o commands.o toollib.o  -static -L../lib \
              -L/var/tmp/dmraid-1.0.0.rc14-7.fc9-root-mockbuild/lib -ldmraid
-ldevmapper -lselinux -lsepol 
/usr/bin/ld: cannot find -ldevmapper
Comment 2 Bug Zapper 2008-05-14 01:28:53 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Heinz Mauelshagen 2008-06-12 09:57:08 EDT
libdevmapper access has been fixed as of mass rebuild on May, 31, right ?
If so, this one can be closed.
Comment 4 Matt Domsch 2008-07-03 12:01:43 EDT
*** Bug 449569 has been marked as a duplicate of this bug. ***
Comment 5 Alasdair Kergon 2008-07-03 13:02:21 EDT
Well the mkinitrd package looks OK, but I still see references to 
dmraid.static in rc.sysinit in initscripts, both F-9 and devel.

The dmraid package still seems to try to build dmraid.static in both - this 
should also be removed.
Comment 6 Fedora Update System 2008-07-03 14:50:15 EDT
dmraid-1.0.0.rc14-8.fc9 has been submitted as an update for Fedora 9
Comment 7 Fedora Update System 2008-07-03 23:38:29 EDT
dmraid-1.0.0.rc14-8.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dmraid'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6070
Comment 8 Fedora Update System 2008-07-18 04:06:04 EDT
dmraid-1.0.0.rc14-8.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.