Bug 43434 - Having finally workaround the set up bugs, registering a system fails
Having finally workaround the set up bugs, registering a system fails
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-04 18:51 EDT by Alan Cox
Modified: 2015-01-07 18:46 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-17 15:15:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2001-06-04 18:51:54 EDT
Look on site. Nor registered systems
Run up2date, 
Tells you to run rhn_register
Run rhn_register
says it worked
Web site still shows no boxes, up2date still fails
Repeat 3 times. Rinse, hold, spin, delete up2date client and install apt

Also btw "Your network" is veyr non obvious as a place to look
Tried the web based one. Got to
"1.Open xterm and log in as root on irongate.swansea.linux.org.uk"

I dont have xterm I have gnome-terminal. I know what to do many wouldnt

Having added one this way I got _THREE_ instances of the machine on the web
page and they actually _disagree_ about packages

It reports '548Mhz' processor while profiling. I know thats ok, a novice
would be confused. Should be rounded off too

Ok so delete all three disagreeing instances and start yet another bloody
rhn_register

Shock horror, my systems arent on the web page again
Clear disk and memory cache
Reload, still not there

BTW the continue/cancel buttons are the wrong way around for the desktop UI
on the OS we ship which is disconcerting

Add another profile for a totally bogus box by the web form 
Both boxes appear delete the web form one and _FINALLY_ the pile of shite
masuqerading as RHN has the right data

Click on the activate your product link from the network pages. Get taken
from an https:// to an http:// insecure site and asked for the product id
in clear text. 

On the add services/costing page include an actual reference to product
registration to get free network services. I had to use _GOOGLE_ to find
that 

Finally to add insult to injury the entire up2date process spewed forth
Traceback (innermost last):
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/share/rhn/up2date/gui.py", line 356, in onPackagePageNext
    self.__refreshCallback)
  File "/usr/share/rhn/up2date/up2date.py", line 1966, in dryRun
    if not changed:
NameError: changed
Traceback (innermost last):
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/share/rhn/up2date/gui.py", line 403, in
onDependencyPagePrepare
    for pkg in self.depPackages:
AttributeError: depPackages

amd died

updating just up2date (again not novice level) got me one that didnt crash
It didnt _work_ either of course.. It complained about kdelibs clashing
with the earlier kdelibs. Telling it not to upgrade kdelibs .. did exactly
the same bogus message

Removed kde2libs kcontrol (this is an update not a clean new 7.1) and
finally this whole sorry pile of dog turd did something approximating
sanity.
Comment 1 Greg DeKoenigsberg 2001-09-17 15:15:44 EDT
A lovely rant.  Does it apply to the current version of RHN?  Mister Gafton, you
have the honor of addressing the estimable Mister Cox's concerns.
Comment 2 Alan Cox 2001-09-17 17:18:05 EDT
The bits of it I've repeated with the new update agent on 7.1 beta failed
differently (proxy problems that are now apparently fixed).

I see no reason to worry about this bug unless I find 7.2 is broken in which
case I'll send in another rant 8)

Note You need to log in before you can comment on or make changes to this bug.