Bug 434359 - setools failed massrebuild attempt for GCC 4.3
setools failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: setools (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris PeBenito
Fedora Extras Quality Assurance
:
Depends On:
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 11:04 EST by Jesse Keating
Modified: 2013-01-09 22:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 09:58:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-02-22 11:04:22 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=443057
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Henning Norén 2008-02-22 15:48:45 EST
gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I../..    -fno-strict-aliasing
-I./../include -I/usr/lib/../include -I/usr/include -I/usr/include -fpic -O2 -g
-pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables -MT netifcon_query.o -MD -MP -MF
.deps/netifcon_query.Tpo -c -o netifcon_query.o netifcon_query.c
mv -f .deps/class_perm_query.Tpo .deps/class_perm_query.Po
iterator.c: In function 'avtab_state_next':
iterator.c:260: error: 'AVTAB_SIZE' undeclared (first use in this function)
iterator.c:260: error: (Each undeclared identifier is reported only once
iterator.c:260: error: for each function it appears in.)
iterator.c: In function 'avtab_state_end':
iterator.c:355: error: 'AVTAB_SIZE' undeclared (first use in this function)
iterator.c: In function 'avtab_state_size':
iterator.c:429: error: 'AVTAB_SIZE' undeclared (first use in this function)
make[4]: *** [iterator.o] Error 1
make[4]: *** Waiting for unfinished jobs....
Comment 2 Chris PeBenito 2008-02-25 11:41:39 EST
This actually has nothing to do with gcc 4.3, its a bug exposed during the gcc
4.3 rebuild.  It is due to changes in libsepol 2.0.20.  An update is coming down
the pipe from upstream to fix this.
Comment 3 Chris PeBenito 2008-04-02 09:58:37 EDT
fixed with setools 3.3.4-1.fc9.  after fixing the libsepol issue, there were gcc
4.3, tcl 8.5, and glibc 2.7 issues that were uncovered, which is what delayed
this from be fixed.

Note You need to log in before you can comment on or make changes to this bug.