Bug 434396 - Macaulay2 failed massrebuild attempt for GCC 4.3
Macaulay2 failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Macaulay2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 11:08 EST by Jesse Keating
Modified: 2013-01-09 22:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 15:53:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-02-22 11:08:39 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=444049
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Jon Stanley 2008-03-01 15:16:34 EST
scratch build 482734
Comment 2 Jon Stanley 2008-03-01 16:37:11 EST
In file included from interface.hpp:4,
                 from interface.cpp:9:
lingb.hpp: At global scope:
lingb.hpp:80: error: declaration of 'typedef struct row_elem<COEFF_TYPE>
coefficient_matrix<COEFF_TYPE>::row_elem'
lingb.hpp:56: error: changes meaning of 'row_elem' from 'struct
row_elem<COEFF_TYPE>'
In file included from interface.cpp:9:
interface.hpp:15: error: declaration of 'typedef class gb_array<typename
CoeffRing::elem> M2Interface<CoeffRing>::gb_array'
lingb.hpp:51: error: changes meaning of 'gb_array' from 'class gb_array<typename
CoeffRing::elem>'
Comment 3 Rex Dieter 2008-03-13 15:53:59 EDT
Macaulay2-1.1 looks like a winner:
http://koji.fedoraproject.org/koji/taskinfo?taskID=515483

Note You need to log in before you can comment on or make changes to this bug.