Bug 434400 - pinentry failed massrebuild attempt for GCC 4.3
pinentry failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pinentry (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: gcc43rebuildfail
  Show dependency treegraph
 
Reported: 2008-02-22 11:09 EST by Jesse Keating
Modified: 2013-01-09 22:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-25 10:31:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-02-22 11:09:09 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=444157
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Rex Dieter 2008-02-22 15:39:03 EST
Looks like some gtk2 header incompatibility.
Comment 2 Rex Dieter 2008-02-22 15:42:29 EST
Hrm, I can't reproduce locally, maybe a transient problem, resubmitting build...
Comment 3 Rex Dieter 2008-02-22 16:07:12 EST
failed again.  ugh.

http://koji.fedoraproject.org/koji/taskinfo?taskID=462244
Comment 4 Rex Dieter 2008-03-25 10:19:10 EDT
gcc -DHAVE_CONFIG_H -I. -I..  -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include
-I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include   -I/usr/include/ncurses
-I../secmem -I../pinentry -Wall  -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386
-mtune=generic -fasynchronous-unwind-tables -Wall -Wcast-align -Wshadow
-Wstrict-prototypes -c gtksecentry.c
In file included from /usr/include/gtk-2.0/gtk/gtkactiongroup.h:34,
                 from /usr/include/gtk-2.0/gtk/gtk.h:38,
                 from pinentry-gtk-2.c:27:
/usr/include/gtk-2.0/gtk/gtkitemfactory.h:50: warning: function declaration
isn't a prototype
In file included from /usr/include/gtk-2.0/gtk/gtkactiongroup.h:34,
                 from /usr/include/gtk-2.0/gtk/gtk.h:38,
                 from gtksecentry.c:40:
/usr/include/gtk-2.0/gtk/gtkitemfactory.h:50: warning: function declaration
isn't a prototype
gtksecentry.c:273: error: conflicting types for 'g_malloc'
/usr/include/glib-2.0/glib/gmem.h:47: error: previous declaration of 'g_malloc'
was here
gtksecentry.c:291: error: conflicting types for 'g_malloc0'
/usr/include/glib-2.0/glib/gmem.h:48: error: previous declaration of 'g_malloc0'
was here
gtksecentry.c:311: error: conflicting types for 'g_realloc'
/usr/include/glib-2.0/glib/gmem.h:49: error: previous declaration of 'g_realloc'
was here
Comment 5 Rex Dieter 2008-03-25 10:31:50 EDT
fixed.

Note You need to log in before you can comment on or make changes to this bug.