Bug 434403 - fedora-ds-base failed massrebuild attempt for GCC 4.3
fedora-ds-base failed massrebuild attempt for GCC 4.3
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: 389-ds-base (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Fedora Extras Quality Assurance
: screened
Depends On:
Blocks: gcc43rebuildfail
  Show dependency treegraph
 
Reported: 2008-02-22 11:09 EST by Jesse Keating
Modified: 2013-01-09 22:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-27 13:02:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed Fix (1.13 KB, patch)
2008-02-23 13:25 EST, Nathan Kinder
no flags Details | Diff

  None (edit)
Description Jesse Keating 2008-02-22 11:09:29 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=444269
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Nathan Kinder 2008-02-23 13:21:13 EST
I believe that we need to define the "_GNU_SOURCE" feature test macro when we
build now.

This problem is due to a change made to /usr/include/bits/socket.h in rawhide
where "struct ucreds" is defined only if "__USE_GNU" is defined.  The
"__USE_GNU" macro is designeded to be set internally by glibc when the
"_GNU_SOURCE" feature test macro is set directly by the program.
Comment 2 Nathan Kinder 2008-02-23 13:25:24 EST
Created attachment 295712 [details]
Proposed Fix

With these changes, I'm able to build fedora-ds-base on Rawhide x86_64.  I
omitted the auto-generated autotools changes from the diffs for readability.
Comment 3 Rich Megginson 2008-02-25 14:17:47 EST
Looks good.  Can you confirm that it builds on el4 and f8 with this fix?
Comment 4 Rich Megginson 2008-02-27 13:02:24 EST
Tagged fixes as FedoraDirSvr110_gcc43 - new source tarball has version 1.1.0.1
pulled from this tag.

Checking in fedora-ds-base.spec;
/cvs/extras/rpms/fedora-ds-base/devel/fedora-ds-base.spec,v  <-- 
fedora-ds-base.spec
new revision: 1.13; previous revision: 1.12
done
Checking in sources;
/cvs/extras/rpms/fedora-ds-base/devel/sources,v  <--  sources
new revision: 1.12; previous revision: 1.11
done

Built in koji

Note You need to log in before you can comment on or make changes to this bug.