Bug 434444 - perl-Sys-Virt failed massrebuild attempt for GCC 4.3
perl-Sys-Virt failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Sys-Virt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
:
Depends On:
Blocks: gcc43rebuildfail
  Show dependency treegraph
 
Reported: 2008-02-22 11:25 EST by Jesse Keating
Modified: 2013-01-09 22:13 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-06 16:43:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-02-22 11:25:02 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=445782
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Daniel Berrange 2008-02-22 11:30:29 EST
This isn't a problem with GCC 4.3 - its a general bug in the Sys-Virt package -
it is trying to use constants which don't exist. We can either patch it to
remove the constants, or wait till I do a new upstream release within next week.
Comment 2 Daniel Berrange 2008-03-05 18:32:02 EST
FYI, new Sys-Virt release should fix this

http://search.cpan.org/~danberr/Sys-Virt-0.1.2/

Comment 3 Steven Pritchard 2008-03-06 16:12:58 EST
0.1.2 is failing tests under mock.

http://koji.fedoraproject.org/koji/getfile?taskID=498164&name=build.log

Either I'm missing a build requirement or rawhide as of a few days ago was
better, because it does build on my system.
Comment 4 Daniel Berrange 2008-03-06 16:16:08 EST
This is a libvirt bug, not a perl-Sys-Virt problem. libvirt is generated bogus
XML causing the Sys-Virt to fail when parsing XML.  I'd disable the test in
question as a temporary workaround till libvirt is fixed
Comment 5 Steven Pritchard 2008-03-06 16:21:00 EST
Consider it done.
Comment 6 Steven Pritchard 2008-03-06 16:43:16 EST
0.1.2-1.fc9 successfully built.

http://koji.fedoraproject.org/koji/taskinfo?taskID=498248

Note You need to log in before you can comment on or make changes to this bug.