Bug 434484 - aiksaurus failed massrebuild attempt for GCC 4.3
aiksaurus failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: aiksaurus (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marc Maurer
Fedora Extras Quality Assurance
:
: 440795 (view as bug list)
Depends On:
Blocks: gcc43errors 440795
  Show dependency treegraph
 
Reported: 2008-02-22 11:29 EST by Jesse Keating
Modified: 2013-01-09 22:15 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-10 15:27:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This patch solve build problem (734 bytes, patch)
2008-04-18 08:42 EDT, Tomo Vuckovic
no flags Details | Diff

  None (edit)
Description Jesse Keating 2008-02-22 11:29:13 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=446812
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 John Poelstra 2008-02-29 15:55:52 EST
i386 build failed

if /bin/sh ../libtool --mode=compile g++ -DHAVE_CONFIG_H -I. -I. -I.. -I..
-DAIK_DATA_DIR=\"/usr/share/aiksaurus/\"   -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -MT AsciiCompare.lo
-MD -MP -MF ".deps/AsciiCompare.Tpo" -c -o AsciiCompare.lo AsciiCompare.cpp; \
	then mv -f ".deps/AsciiCompare.Tpo" ".deps/AsciiCompare.Plo"; else rm -f
".deps/AsciiCompare.Tpo"; exit 1; fi
 g++ -DHAVE_CONFIG_H -I. -I. -I.. -I.. -DAIK_DATA_DIR=\"/usr/share/aiksaurus/\"
-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables -MT AiksaurusException.lo -MD -MP -MF
.deps/AiksaurusException.Tpo -c AiksaurusException.cpp  -fPIC -DPIC -o
.libs/AiksaurusException.o
if /bin/sh ../libtool --mode=compile g++ -DHAVE_CONFIG_H -I. -I. -I.. -I..
-DAIK_DATA_DIR=\"/usr/share/aiksaurus/\"   -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -MT MeaningsFile.lo
-MD -MP -MF ".deps/MeaningsFile.Tpo" -c -o MeaningsFile.lo MeaningsFile.cpp; \
	then mv -f ".deps/MeaningsFile.Tpo" ".deps/MeaningsFile.Plo"; else rm -f
".deps/MeaningsFile.Tpo"; exit 1; fi
 g++ -DHAVE_CONFIG_H -I. -I. -I.. -I.. -DAIK_DATA_DIR=\"/usr/share/aiksaurus/\"
-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables -MT AsciiCompare.lo -MD -MP -MF
.deps/AsciiCompare.Tpo -c AsciiCompare.cpp  -fPIC -DPIC -o .libs/AsciiCompare.o
if /bin/sh ../libtool --mode=compile g++ -DHAVE_CONFIG_H -I. -I. -I.. -I..
-DAIK_DATA_DIR=\"/usr/share/aiksaurus/\"   -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -MT WordsFile.lo
-MD -MP -MF ".deps/WordsFile.Tpo" -c -o WordsFile.lo WordsFile.cpp; \
	then mv -f ".deps/WordsFile.Tpo" ".deps/WordsFile.Plo"; else rm -f
".deps/WordsFile.Tpo"; exit 1; fi
 g++ -DHAVE_CONFIG_H -I. -I. -I.. -I.. -DAIK_DATA_DIR=\"/usr/share/aiksaurus/\"
-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables -MT WordsFile.lo -MD -MP -MF .deps/WordsFile.Tpo -c
WordsFile.cpp  -fPIC -DPIC -o .libs/WordsFile.o
if /bin/sh ../libtool --mode=compile g++ -DHAVE_CONFIG_H -I. -I. -I.. -I..
-DAIK_DATA_DIR=\"/usr/share/aiksaurus/\"   -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -MT AiksaurusC.lo
-MD -MP -MF ".deps/AiksaurusC.Tpo" -c -o AiksaurusC.lo AiksaurusC.cpp; \
	then mv -f ".deps/AiksaurusC.Tpo" ".deps/AiksaurusC.Plo"; else rm -f
".deps/AiksaurusC.Tpo"; exit 1; fi
 g++ -DHAVE_CONFIG_H -I. -I. -I.. -I.. -DAIK_DATA_DIR=\"/usr/share/aiksaurus/\"
-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables -MT MeaningsFile.lo -MD -MP -MF
.deps/MeaningsFile.Tpo -c MeaningsFile.cpp  -fPIC -DPIC -o .libs/MeaningsFile.o
if g++ -DHAVE_CONFIG_H -I. -I. -I.. -I..
-DAIK_DATA_DIR=\"/usr/share/aiksaurus/\"   -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -MT aiksaurus.t.o
-MD -MP -MF ".deps/aiksaurus.t.Tpo" -c -o aiksaurus.t.o aiksaurus.t.cpp; \
	then mv -f ".deps/aiksaurus.t.Tpo" ".deps/aiksaurus.t.Po"; else rm -f
".deps/aiksaurus.t.Tpo"; exit 1; fi
aiksaurus.t.cpp: In function 'void checkError(const Aiksaurus&)':
aiksaurus.t.cpp:59: error: 'exit' was not declared in this scope
aiksaurus.t.cpp: In function 'int main(int, const char**)':
aiksaurus.t.cpp:138: error: 'exit' was not declared in this scope
aiksaurus.t.cpp:145: error: 'exit' was not declared in this scope
aiksaurus.t.cpp:153: error: 'exit' was not declared in this scope
make[2]: *** [aiksaurus.t.o] Error 1
make[2]: *** Waiting for unfinished jobs....
 g++ -DHAVE_CONFIG_H -I. -I. -I.. -I.. -DAIK_DATA_DIR=\"/usr/share/aiksaurus/\"
-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables -MT AiksaurusC.lo -MD -MP -MF .deps/AiksaurusC.Tpo
-c AiksaurusC.cpp  -fPIC -DPIC -o .libs/AiksaurusC.o
make[2]: Leaving directory `/builddir/build/BUILD/aiksaurus-1.2.1/base'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/aiksaurus-1.2.1'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.85679 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.85679 (%build)
EXCEPTION: Command failed. See logs for output.
 # bash --login -c 'rpmbuild -bb --target i386 --nodeps
//builddir/build/SPECS/aiksaurus.spec'
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/mock/trace_decorator.py", line 70, in trace
    result = func(*args, **kw)
  File "/usr/lib/python2.4/site-packages/mock/util.py", line 287, in do
    raise mock.exception.Error, ("Command failed. See logs for output.\n # %s" %
(command,), ret)
Error: Command failed. See logs for output.
 # bash --login -c 'rpmbuild -bb --target i386 --nodeps
//builddir/build/SPECS/aiksaurus.spec'
LEAVE do --> EXCEPTION RAISED
Comment 2 Tomo Vuckovic 2008-04-18 08:42:20 EDT
Created attachment 302879 [details]
This patch solve build problem

Solve build problem with gcc 4.3.0
Comment 3 Bug Zapper 2008-05-14 01:33:45 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Matt Domsch 2008-07-03 11:56:19 EDT
*** Bug 440795 has been marked as a duplicate of this bug. ***
Comment 5 FTBFS 2008-09-05 12:09:20 EDT
This package has Failed to Build From Source for many months.  Per
http://fedoraproject.org/wiki/FTBFS, this package is now proposed for
removal from the distribution.  Please address this FTBFS bug
immediately, or this package will be removed from the distribution
within the next few weeks.

Thank you for your continued contributions to Fedora, and your
commitment to ensuring Fedora packages remain buildable from source
code.
Comment 6 FTBFS 2008-09-05 12:09:43 EDT
This package has Failed to Build From Source for many months.  Per
http://fedoraproject.org/wiki/FTBFS, this package is now proposed for
removal from the distribution.  Please address this FTBFS bug
immediately, or this package will be removed from the distribution
within the next few weeks.

Thank you for your continued contributions to Fedora, and your
commitment to ensuring Fedora packages remain buildable from source
code.
Comment 7 Matt Domsch 2008-09-10 15:27:20 EDT
I applied a patch similar to that in comment #2 and have rebuilt.  The patch in comment #2 is probably a bit better, the package maintainer should review at the next version bump.  Closing.

Note You need to log in before you can comment on or make changes to this bug.