Bug 434485 - gtkmathview failed massrebuild attempt for GCC 4.3
gtkmathview failed massrebuild attempt for GCC 4.3
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gtkmathview (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marc Maurer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 11:29 EST by Jesse Keating
Modified: 2013-01-09 22:15 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-14 17:09:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-02-22 11:29:19 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=446821
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 John Poelstra 2008-02-29 15:55:04 EST
build failed on ppc64

 g++ -DHAVE_CONFIG_H -I. -I. -I../../.. -I../../../auto -I../../../auto
-I../../../src/common -I../../../src/common/mathvariants/
-I../../../src/engine/common -I../../../src/frontend/common
-I../../../src/backend/common -DGMV_MathView_DLL -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m64 -mminimal-toc -W -Wall -MT libmathml_la-MathMLTableFormatter.lo -MD -MP -MF
.deps/libmathml_la-MathMLTableFormatter.Tpo -c MathMLTableFormatter.cc  -fPIC
-DPIC -o .libs/libmathml_la-MathMLTableFormatter.o
 g++ -DHAVE_CONFIG_H -I. -I. -I../../.. -I../../../auto -I../../../auto
-I../../../src/common -I../../../src/common/mathvariants/
-I../../../src/engine/common -I../../../src/frontend/common
-I../../../src/backend/common -DGMV_MathView_DLL -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m64 -mminimal-toc -W -Wall -MT libmathml_la-MathMLTextElement.lo -MD -MP -MF
.deps/libmathml_la-MathMLTextElement.Tpo -c MathMLTextElement.cc  -fPIC -DPIC -o
.libs/libmathml_la-MathMLTextElement.o
 g++ -DHAVE_CONFIG_H -I. -I. -I../../.. -I../../../auto -I../../../auto
-I../../../src/common -I../../../src/common/mathvariants/
-I../../../src/engine/common -I../../../src/frontend/common
-I../../../src/backend/common -DGMV_MathView_DLL -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m64 -mminimal-toc -W -Wall -MT libmathml_la-MathMLUnderOverElement.lo -MD -MP
-MF .deps/libmathml_la-MathMLUnderOverElement.Tpo -c MathMLUnderOverElement.cc 
-fPIC -DPIC -o .libs/libmathml_la-MathMLUnderOverElement.o
if /bin/sh ../../../libtool --mode=compile g++ -DHAVE_CONFIG_H -I. -I.
-I../../.. -I../../../auto -I../../../auto -I../../../src/common
-I../../../src/common/mathvariants/ -I../../../src/engine/common
-I../../../src/frontend/common -I../../../src/backend/common  -DGMV_MathView_DLL
  -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m64 -mminimal-toc -W -Wall -MT
libmathml_la-MathMLValueConversion.lo -MD -MP -MF
".deps/libmathml_la-MathMLValueConversion.Tpo" \
	  -c -o libmathml_la-MathMLValueConversion.lo `test -f
'MathMLValueConversion.cc' || echo './'`MathMLValueConversion.cc; \
	then mv -f ".deps/libmathml_la-MathMLValueConversion.Tpo"
".deps/libmathml_la-MathMLValueConversion.Plo"; \
	else rm -f ".deps/libmathml_la-MathMLValueConversion.Tpo"; exit 1; \
	fi
MathMLTableFormatter.cc: In member function 'void
MathMLTableFormatter::init(const FormattingContext&, unsigned int, unsigned int,
const std::vector<SmartPtr<MathMLTableCellElement>,
std::allocator<SmartPtr<MathMLTableCellElement> > >&, const
std::vector<SmartPtr<MathMLTableCellElement>,
std::allocator<SmartPtr<MathMLTableCellElement> > >&, const SmartPtr<Value>&,
const SmartPtr<Value>&, const SmartPtr<Value>&, const SmartPtr<Value>&, const
SmartPtr<Value>&, const SmartPtr<Value>&, const SmartPtr<Value>&, const
SmartPtr<Value>&, const SmartPtr<Value>&, const SmartPtr<Value>&)':
MathMLTableFormatter.cc:91: error: 'find_if' is not a member of 'std'
 g++ -DHAVE_CONFIG_H -I. -I. -I../../.. -I../../../auto -I../../../auto
-I../../../src/common -I../../../src/common/mathvariants/
-I../../../src/engine/common -I../../../src/frontend/common
-I../../../src/backend/common -DGMV_MathView_DLL -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m64 -mminimal-toc -W -Wall -MT libmathml_la-MathMLTableElement.lo -MD -MP -MF
.deps/libmathml_la-MathMLTableElement.Tpo -c MathMLTableElement.cc  -fPIC -DPIC
-o .libs/libmathml_la-MathMLTableElement.o
MathMLTableFormatter.cc:104: warning: comparison of unsigned expression >= 0 is
always true
MathMLTableFormatter.cc:105: warning: comparison of unsigned expression >= 0 is
always true
MathMLTableFormatter.cc: At global scope:
MathMLTableFormatter.cc:193: warning: unused parameter 'ctxt'
MathMLTableFormatter.cc:193: warning: unused parameter 'availableWidth'
MathMLTableFormatter.cc:193: warning: unused parameter 'width'
 g++ -DHAVE_CONFIG_H -I. -I. -I../../.. -I../../../auto -I../../../auto
-I../../../src/common -I../../../src/common/mathvariants/
-I../../../src/engine/common -I../../../src/frontend/common
-I../../../src/backend/common -DGMV_MathView_DLL -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m64 -mminimal-toc -W -Wall -MT libmathml_la-MathMLTextNode.lo -MD -MP -MF
.deps/libmathml_la-MathMLTextNode.Tpo -c MathMLTextNode.cc  -fPIC -DPIC -o
.libs/libmathml_la-MathMLTextNode.o
make[4]: *** [libmathml_la-MathMLTableFormatter.lo] Error 1
make[4]: *** Waiting for unfinished jobs....
 g++ -DHAVE_CONFIG_H -I. -I. -I../../.. -I../../../auto -I../../../auto
-I../../../src/common -I../../../src/common/mathvariants/
-I../../../src/engine/common -I../../../src/frontend/common
-I../../../src/backend/common -DGMV_MathView_DLL -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m64 -mminimal-toc -W -Wall -MT libmathml_la-MathMLTokenElement.lo -MD -MP -MF
.deps/libmathml_la-MathMLTokenElement.Tpo -c MathMLTokenElement.cc  -fPIC -DPIC
-o .libs/libmathml_la-MathMLTokenElement.o
 g++ -DHAVE_CONFIG_H -I. -I. -I../../.. -I../../../auto -I../../../auto
-I../../../src/common -I../../../src/common/mathvariants/
-I../../../src/engine/common -I../../../src/frontend/common
-I../../../src/backend/common -DGMV_MathView_DLL -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m64 -mminimal-toc -W -Wall -MT libmathml_la-MathMLValueConversion.lo -MD -MP
-MF .deps/libmathml_la-MathMLValueConversion.Tpo -c MathMLValueConversion.cc 
-fPIC -DPIC -o .libs/libmathml_la-MathMLValueConversion.o
make[4]: Leaving directory
`/builddir/build/BUILD/gtkmathview-0.7.6/src/engine/mathml'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/builddir/build/BUILD/gtkmathview-0.7.6/src/engine'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/builddir/build/BUILD/gtkmathview-0.7.6/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/gtkmathview-0.7.6'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.88973 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.88973 (%build)
EXCEPTION: Command failed. See logs for output.
 # bash --login -c 'rpmbuild -bb --target ppc64 --nodeps
//builddir/build/SPECS/gtkmathview.spec'
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/mock/trace_decorator.py", line 70, in trace
    result = func(*args, **kw)
  File "/usr/lib/python2.4/site-packages/mock/util.py", line 287, in do
    raise mock.exception.Error, ("Command failed. See logs for output.\n # %s" %
(command,), ret)
Error: Command failed. See logs for output.
 # bash --login -c 'rpmbuild -bb --target ppc64 --nodeps
//builddir/build/SPECS/gtkmathview.spec'
LEAVE do --> EXCEPTION RAISED

Comment 2 Doug Chapman 2008-03-14 17:09:25 EDT
Varous files needed either:

#include <algorithm>

or 

#include <cstring>

due to gcc 4.3 changes


Fixed in gtkmathview-0.7.6-7.fc9

Note You need to log in before you can comment on or make changes to this bug.