Bug 434523 - lineakd failed massrebuild attempt for GCC 4.3
lineakd failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lineakd (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Petersen
Fedora Extras Quality Assurance
:
: 440774 (view as bug list)
Depends On:
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 11:33 EST by Jesse Keating
Modified: 2013-01-09 22:17 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-10 15:53:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-02-22 11:33:09 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=447891
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 John Poelstra 2008-02-29 15:41:15 EST
i386 build failed

../lineak/lkbd.h:84: warning: type qualifiers ignored on function return type
pluginmanager.cpp: In member function 'bool PluginManager::loadPlugin(const
std::string&)':
pluginmanager.cpp:122: warning: suggest parentheses around && within ||
pluginmanager.cpp: In member function 'std::vector<std::basic_string<char,
std::char_traits<char>, std::allocator<char> >,
std::allocator<std::basic_string<char, std::char_traits<char>,
std::allocator<char> > > > PluginManager::scanForPlugins(const std::string&)':
pluginmanager.cpp:466: error: 'strcmp' was not declared in this scope
make[2]: *** [pluginmanager.lo] Error 1
make[2]: *** Waiting for unfinished jobs....
In file included from ../lineak/lconfig.h:34,
                 from displayctrl.cpp:21:
../lineak/lconfigdata.h:34: warning: type qualifiers ignored on function return type
In file included from ../lineak/lconfig.h:35,
                 from displayctrl.cpp:21:
../lineak/lcommand.h:51: warning: type qualifiers ignored on function return type
In file included from displayctrl.cpp:21:
../lineak/lconfig.h:110: warning: type qualifiers ignored on function return type
In file included from ../lineak/lineak_core_functions.h:29,
                 from displayctrl.cpp:23:
../lineak/lobject.h:52: warning: type qualifiers ignored on function return type
../lineak/lobject.h:53: warning: type qualifiers ignored on function return type
displayctrl.cpp:32: warning: unused parameter 'config'
displayctrl.cpp:37: warning: unused parameter 'config'
make[2]: Leaving directory `/builddir/build/BUILD/lineakd-0.9/lineak'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/lineakd-0.9'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.81079 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.81079 (%build)
EXCEPTION: Command failed. See logs for output.
 # bash --login -c 'rpmbuild -bb --target i386 --nodeps
//builddir/build/SPECS/lineakd.spec'
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/mock/trace_decorator.py", line 70, in trace
    result = func(*args, **kw)
  File "/usr/lib/python2.4/site-packages/mock/util.py", line 287, in do
    raise mock.exception.Error, ("Command failed. See logs for output.\n # %s" %
(command,), ret)
Error: Command failed. See logs for output.
 # bash --login -c 'rpmbuild -bb --target i386 --nodeps
//builddir/build/SPECS/lineakd.spec'
LEAVE do --> EXCEPTION RAISED
Comment 2 Bug Zapper 2008-05-14 01:34:15 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Matt Domsch 2008-07-03 12:04:31 EDT
*** Bug 440774 has been marked as a duplicate of this bug. ***
Comment 4 FTBFS 2008-09-05 12:13:07 EDT
This package has Failed to Build From Source for many months.  Per
http://fedoraproject.org/wiki/FTBFS, this package is now proposed for
removal from the distribution.  Please address this FTBFS bug
immediately, or this package will be removed from the distribution
within the next few weeks.

Thank you for your continued contributions to Fedora, and your
commitment to ensuring Fedora packages remain buildable from source
code.
Comment 5 Matt Domsch 2008-09-10 15:53:57 EDT
fixed, building as 0.9-8.fc10.

Note You need to log in before you can comment on or make changes to this bug.