Bug 434529 - gdmap failed massrebuild attempt for GCC 4.3
gdmap failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdmap (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Damien Durand
Fedora Extras Quality Assurance
:
: 440889 (view as bug list)
Depends On:
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 11:33 EST by Jesse Keating
Modified: 2013-01-09 22:17 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-16 23:37:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-02-22 11:33:48 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=452282
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 John Poelstra 2008-02-29 15:34:18 EST
x86_64 build failed

if gcc -DHAVE_CONFIG_H -I. -I. -I..   
-DGDMAP_LOCALE_DIR=\""/usr/share/locale"\"
-DPACKAGE_DATA_DIR=\""/usr/share/gdmap"\" -I/usr/include/gtk-2.0
-I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo
-I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include 
 -DGTK_DISABLE_DEPRECATED -I/usr/include/libxml2   -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m64 -mtune=generic -D_GNU_SOURCE -Wno-pointer-sign -MT gdmap-about.o -MD -MP
-MF ".deps/gdmap-about.Tpo" -c -o gdmap-about.o `test -f 'about.c' || echo
'./'`about.c; \
	then mv -f ".deps/gdmap-about.Tpo" ".deps/gdmap-about.Po"; else rm -f
".deps/gdmap-about.Tpo"; exit 1; fi
if gcc -DHAVE_CONFIG_H -I. -I. -I..   
-DGDMAP_LOCALE_DIR=\""/usr/share/locale"\"
-DPACKAGE_DATA_DIR=\""/usr/share/gdmap"\" -I/usr/include/gtk-2.0
-I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo
-I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include 
 -DGTK_DISABLE_DEPRECATED -I/usr/include/libxml2   -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m64 -mtune=generic -D_GNU_SOURCE -Wno-pointer-sign -MT gdmap-tree.o -MD -MP -MF
".deps/gdmap-tree.Tpo" -c -o gdmap-tree.o `test -f 'tree.c' || echo './'`tree.c; \
	then mv -f ".deps/gdmap-tree.Tpo" ".deps/gdmap-tree.Po"; else rm -f
".deps/gdmap-tree.Tpo"; exit 1; fi
gui_support.c: In function 'ui_create_section':
gui_support.c:35: error: expected '=', ',', ';', 'asm' or '__attribute__' before
'*' token
gui_support.c:35: error: 'tips' undeclared (first use in this function)
gui_support.c:35: error: (Each undeclared identifier is reported only once
gui_support.c:35: error: for each function it appears in.)
gui_support.c:62: warning: implicit declaration of function 'gtk_tooltips_new'
gui_support.c:63: warning: implicit declaration of function 'gtk_tooltips_set_tip'
make[2]: *** [gdmap-gui_support.o] Error 1
make[2]: *** Waiting for unfinished jobs....
tree.c:33: warning: 'tree_print' defined but not used
preferences.c: In function 'pref_save':
preferences.c:54: warning: ignoring return value of 'fwrite', declared with
attribute warn_unused_result
about.c: In function 'gui_show_about':
about.c:47: warning: implicit declaration of function 'gtk_about_dialog_set_name'
make[2]: Leaving directory `/builddir/build/BUILD/gdmap-0.7.5/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/gdmap-0.7.5'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.33490 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.33490 (%build)
EXCEPTION: Command failed. See logs for output.
 # bash --login -c 'rpmbuild -bb --target x86_64 --nodeps
//builddir/build/SPECS/gdmap.spec'
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/mock/trace_decorator.py", line 70, in trace
    result = func(*args, **kw)
  File "/usr/lib/python2.4/site-packages/mock/util.py", line 287, in do
    raise mock.exception.Error, ("Command failed. See logs for output.\n # %s" %
(command,), ret)
Error: Command failed. See logs for output.
 # bash --login -c 'rpmbuild -bb --target x86_64 --nodeps
//builddir/build/SPECS/gdmap.spec'
LEAVE do --> EXCEPTION RAISED
Comment 2 Bug Zapper 2008-05-14 01:34:30 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Matt Domsch 2008-07-03 13:18:29 EDT
*** Bug 440889 has been marked as a duplicate of this bug. ***
Comment 4 FTBFS 2008-09-05 12:11:32 EDT
This package has Failed to Build From Source for many months.  Per
http://fedoraproject.org/wiki/FTBFS, this package is now proposed for
removal from the distribution.  Please address this FTBFS bug
immediately, or this package will be removed from the distribution
within the next few weeks.

Thank you for your continued contributions to Fedora, and your
commitment to ensuring Fedora packages remain buildable from source
code.

Note You need to log in before you can comment on or make changes to this bug.