Bug 434531 - gstm failed massrebuild attempt for GCC 4.3
gstm failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gstm (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Damien Durand
Fedora Extras Quality Assurance
:
: 440719 (view as bug list)
Depends On:
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 11:34 EST by Jesse Keating
Modified: 2013-01-09 22:17 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-16 23:14:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch for gstm.spec to build properly (554 bytes, patch)
2008-09-09 13:56 EDT, Steven Bakker
no flags Details | Diff

  None (edit)
Description Jesse Keating 2008-02-22 11:34:00 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=452291
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 John Poelstra 2008-02-28 12:41:28 EST
x86_64 build failed

make[1]: Entering directory `/builddir/build/BUILD/gstm-1.2'
Making all in src
make[2]: Entering directory `/builddir/build/BUILD/gstm-1.2/src'
if gcc -DHAVE_CONFIG_H -I. -I. -I.. -DPACKAGE_DATA_DIR=\""/usr/share"\"
-DPACKAGE_LOCALE_DIR=\""/usr/share/locale"\" -DPACKAGE_BINDIR=\""/usr/bin"\"
-DORBIT2=1 -pthread -I/usr/include/libgnomeui-2.0 -I/usr/include/libgnome-2.0
-I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0
-I/usr/include/gtk-2.0 -I/usr/include/gnome-vfs-2.0
-I/usr/lib64/gnome-vfs-2.0/include -I/usr/include/glib-2.0
-I/usr/lib64/glib-2.0/include -I/usr/include/libbonobo-2.0
-I/usr/include/orbit-2.0 -I/usr/include/bonobo-activation-2.0
-I/usr/include/libart-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0
-I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/gconf/2      -O2 -g
-pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m64 -mtune=generic -MT main.o -MD -MP -MF
".deps/main.Tpo" -c -o main.o main.c; \
	then mv -f ".deps/main.Tpo" ".deps/main.Po"; else rm -f ".deps/main.Tpo"; exit
1; fi
if gcc -DHAVE_CONFIG_H -I. -I. -I.. -DPACKAGE_DATA_DIR=\""/usr/share"\"
-DPACKAGE_LOCALE_DIR=\""/usr/share/locale"\" -DPACKAGE_BINDIR=\""/usr/bin"\"
-DORBIT2=1 -pthread -I/usr/include/libgnomeui-2.0 -I/usr/include/libgnome-2.0
-I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0
-I/usr/include/gtk-2.0 -I/usr/include/gnome-vfs-2.0
-I/usr/lib64/gnome-vfs-2.0/include -I/usr/include/glib-2.0
-I/usr/lib64/glib-2.0/include -I/usr/include/libbonobo-2.0
-I/usr/include/orbit-2.0 -I/usr/include/bonobo-activation-2.0
-I/usr/include/libart-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0
-I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/gconf/2      -O2 -g
-pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m64 -mtune=generic -MT support.o -MD -MP -MF
".deps/support.Tpo" -c -o support.o support.c; \
	then mv -f ".deps/support.Tpo" ".deps/support.Po"; else rm -f
".deps/support.Tpo"; exit 1; fi
In file included from main.c:35:
conffile.h:9:31: error: libxml/xmlmemory.h: No such file or directory
conffile.h:10:28: error: libxml/parser.h: No such file or directory
conffile.h:11:30: error: libxml/encoding.h: No such file or directory
conffile.h:12:31: error: libxml/xmlwriter.h: No such file or directory
In file included from main.c:35:
conffile.h:19: error: expected specifier-qualifier-list before 'xmlChar'
conffile.h:27: error: expected specifier-qualifier-list before 'xmlChar'
conffile.h:46: error: expected ')' before 'doc'
main.c: In function 'main':
main.c:66: error: 'LIBXML_TEST_VERSION' undeclared (first use in this function)
main.c:66: error: (Each undeclared identifier is reported only once
main.c:66: error: for each function it appears in.)
main.c:69: error: expected ';' before 'bindtextdomain'
main.c:98: warning: implicit declaration of function 'docklet_x11_create'
main.c:59: warning: unused variable 'thetunnel'
main.c: In function 'gstm_process_autostart':
main.c:200: error: 'struct sshtunnel' has no member named 'autostart'
main.c:201: error: 'struct sshtunnel' has no member named 'active'
main.c:203: warning: implicit declaration of function 'gstm_ssht_starttunnel'
main.c: In function 'gstm_populate_treeview':
main.c:219: warning: suggest parentheses around assignment used as truth value
main.c:229: error: 'struct sshtunnel' has no member named 'active'
main.c:232: error: 'struct sshtunnel' has no member named 'name'
main.c:238: error: 'struct sshtunnel' has no member named 'name'
main.c:216: warning: unused variable 'error'
main.c:214: warning: unused variable 'selection'
main.c:211: warning: unused variable 'renderer'
main.c: In function 'gstm_quit':
main.c:256: warning: implicit declaration of function 'gstm_ssht_stoptunnel'
main.c:264: warning: implicit declaration of function 'docklet_x11_destroy'
make[2]: *** [main.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/builddir/build/BUILD/gstm-1.2/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/gstm-1.2'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.93546 (%build)
Comment 2 Bug Zapper 2008-05-14 01:34:37 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Matt Domsch 2008-07-03 13:38:08 EDT
*** Bug 440719 has been marked as a duplicate of this bug. ***
Comment 4 FTBFS 2008-09-05 12:11:41 EDT
This package has Failed to Build From Source for many months.  Per
http://fedoraproject.org/wiki/FTBFS, this package is now proposed for
removal from the distribution.  Please address this FTBFS bug
immediately, or this package will be removed from the distribution
within the next few weeks.

Thank you for your continued contributions to Fedora, and your
commitment to ensuring Fedora packages remain buildable from source
code.
Comment 5 Steven Bakker 2008-09-09 13:53:23 EDT
The spec file needs only two minor changes:

 * a CFLAGS=-I/usr/include/libxml2 added to the %configure.
 * the removal of "--add-category Internet" from desktop-file-install.

I'll create a patch and attach it. I would really appreciate it if someone can incorporate it. I use gstm daily ;-)

-- Steven
Comment 6 Steven Bakker 2008-09-09 13:56:34 EDT
Created attachment 316223 [details]
Patch for gstm.spec to build properly

This patch adds a CFLAGS to the %configure line and removes a bogus category from the desktop-file-install call.

Note You need to log in before you can comment on or make changes to this bug.