Bug 434532 - libgtksourceviewmm failed massrebuild attempt for GCC 4.3
Summary: libgtksourceviewmm failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libgtksourceviewmm   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Damien Durand
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 440877 (view as bug list)
Depends On:
Blocks: gcc43errors
TreeView+ depends on / blocked
 
Reported: 2008-02-22 16:34 UTC by Jesse Keating
Modified: 2013-01-10 03:17 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-05 13:59:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jesse Keating 2008-02-22 16:34:06 UTC
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=452293
Exit code was 1, check the build.log for the failed buildArch task.

Comment 1 John Poelstra 2008-02-28 17:36:23 UTC
i386 build fails

 g++ -DHAVE_CONFIG_H -DG_LOG_DOMAIN=\"gtksourceviewmm\" -I../../gtksourceview
-I../../gtksourceview -I/usr/include/gtkmm-2.4 -I/usr/lib/gtkmm-2.4/include
-I/usr/include/glibmm-2.4 -I/usr/lib/glibmm-2.4/include -I/usr/include/gdkmm-2.4
-I/usr/lib/gdkmm-2.4/include -I/usr/include/pangomm-1.4 -I/usr/include/atkmm-1.6
-I/usr/include/gtk-2.0 -I/usr/include/sigc++-2.0 -I/usr/lib/sigc++-2.0/include
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/lib/gtk-2.0/include
-I/usr/include/cairomm-1.0 -I/usr/include/pango-1.0 -I/usr/include/cairo
-I/usr/include/atk-1.0 -I/usr/include/gtksourceview-1.0 -I/usr/include/libxml2
-I/usr/include/libgnomeprint-2.2 -I/usr/include/libart-2.0 -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -MT
sourcetagstyle.lo -MD -MP -MF .deps/sourcetagstyle.Tpo -c sourcetagstyle.cc 
-fPIC -DPIC -o .libs/sourcetagstyle.o
 g++ -DHAVE_CONFIG_H -DG_LOG_DOMAIN=\"gtksourceviewmm\" -I../../gtksourceview
-I../../gtksourceview -I/usr/include/gtkmm-2.4 -I/usr/lib/gtkmm-2.4/include
-I/usr/include/glibmm-2.4 -I/usr/lib/glibmm-2.4/include -I/usr/include/gdkmm-2.4
-I/usr/lib/gdkmm-2.4/include -I/usr/include/pangomm-1.4 -I/usr/include/atkmm-1.6
-I/usr/include/gtk-2.0 -I/usr/include/sigc++-2.0 -I/usr/lib/sigc++-2.0/include
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/lib/gtk-2.0/include
-I/usr/include/cairomm-1.0 -I/usr/include/pango-1.0 -I/usr/include/cairo
-I/usr/include/atk-1.0 -I/usr/include/gtksourceview-1.0 -I/usr/include/libxml2
-I/usr/include/libgnomeprint-2.2 -I/usr/include/libart-2.0 -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -MT
sourcestylescheme.lo -MD -MP -MF .deps/sourcestylescheme.Tpo -c
sourcestylescheme.cc  -fPIC -DPIC -o .libs/sourcestylescheme.o
sourcetagstyle.cc: In constructor 'gtksourceview::SourceTagStyle::SourceTagStyle()':
sourcetagstyle.cc:37: error: 'memset' was not declared in this scope
make[5]: *** [sourcetagstyle.lo] Error 1
make[5]: *** Waiting for unfinished jobs....
make[5]: Leaving directory
`/builddir/build/BUILD/libgtksourceviewmm-0.3.1/gtksourceview/gtksourceviewmm'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory
`/builddir/build/BUILD/libgtksourceviewmm-0.3.1/gtksourceview/gtksourceviewmm'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory
`/builddir/build/BUILD/libgtksourceviewmm-0.3.1/gtksourceview'
make[2]: *** [all] Error 2
make[2]: Leaving directory
`/builddir/build/BUILD/libgtksourceviewmm-0.3.1/gtksourceview'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/libgtksourceviewmm-0.3.1'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.46687 (%build)


Comment 2 Bug Zapper 2008-05-14 05:34:44 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Matt Domsch 2008-07-03 17:17:27 UTC
*** Bug 440877 has been marked as a duplicate of this bug. ***

Comment 4 Matt Domsch 2008-09-05 13:59:05 UTC
builds 2008-08-24


Note You need to log in before you can comment on or make changes to this bug.