Bug 434533 - lostirc failed massrebuild attempt for GCC 4.3
lostirc failed massrebuild attempt for GCC 4.3
Status: CLOSED DUPLICATE of bug 440921
Product: Fedora
Classification: Fedora
Component: lostirc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Damien Durand
Fedora Extras Quality Assurance
:
Depends On:
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 11:34 EST by Jesse Keating
Modified: 2013-01-09 22:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-05 12:26:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-02-22 11:34:13 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=452294
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 John Poelstra 2008-02-29 15:31:54 EST
x86_64 failed

make[1]: Entering directory `/builddir/build/BUILD/lostirc-0.4.6'
Making all in intl
make[2]: Entering directory `/builddir/build/BUILD/lostirc-0.4.6/intl'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/builddir/build/BUILD/lostirc-0.4.6/intl'
Making all in po
make[2]: Entering directory `/builddir/build/BUILD/lostirc-0.4.6/po'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/builddir/build/BUILD/lostirc-0.4.6/po'
Making all in src
make[2]: Entering directory `/builddir/build/BUILD/lostirc-0.4.6/src'
Making all in libirc
make[3]: Entering directory `/builddir/build/BUILD/lostirc-0.4.6/src/libirc'
if g++ -DHAVE_CONFIG_H -I. -I. -I../.. -I/usr/include/glibmm-2.4
-I/usr/lib64/glibmm-2.4/include -I/usr/include/sigc++-2.0
-I/usr/lib64/sigc++-2.0/include -I/usr/include/glib-2.0
-I/usr/lib64/glib-2.0/include   -I../../intl    -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m64 -mtune=generic -Wall -MT ServerConnection.o -MD -MP -MF
".deps/ServerConnection.Tpo" -c -o ServerConnection.o ServerConnection.cpp; \
	then mv -f ".deps/ServerConnection.Tpo" ".deps/ServerConnection.Po"; else rm -f
".deps/ServerConnection.Tpo"; exit 1; fi
if g++ -DHAVE_CONFIG_H -I. -I. -I../.. -I/usr/include/glibmm-2.4
-I/usr/lib64/glibmm-2.4/include -I/usr/include/sigc++-2.0
-I/usr/lib64/sigc++-2.0/include -I/usr/include/glib-2.0
-I/usr/lib64/glib-2.0/include   -I../../intl    -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m64 -mtune=generic -Wall -MT Commands.o -MD -MP -MF ".deps/Commands.Tpo" -c -o
Commands.o Commands.cpp; \
	then mv -f ".deps/Commands.Tpo" ".deps/Commands.Po"; else rm -f
".deps/Commands.Tpo"; exit 1; fi
if g++ -DHAVE_CONFIG_H -I. -I. -I../.. -I/usr/include/glibmm-2.4
-I/usr/lib64/glibmm-2.4/include -I/usr/include/sigc++-2.0
-I/usr/lib64/sigc++-2.0/include -I/usr/include/glib-2.0
-I/usr/lib64/glib-2.0/include   -I../../intl    -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m64 -mtune=generic -Wall -MT ConfigHandler.o -MD -MP -MF
".deps/ConfigHandler.Tpo" -c -o ConfigHandler.o ConfigHandler.cpp; \
	then mv -f ".deps/ConfigHandler.Tpo" ".deps/ConfigHandler.Po"; else rm -f
".deps/ConfigHandler.Tpo"; exit 1; fi
if g++ -DHAVE_CONFIG_H -I. -I. -I../.. -I/usr/include/glibmm-2.4
-I/usr/lib64/glibmm-2.4/include -I/usr/include/sigc++-2.0
-I/usr/lib64/sigc++-2.0/include -I/usr/include/glib-2.0
-I/usr/lib64/glib-2.0/include   -I../../intl    -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m64 -mtune=generic -Wall -MT LostIRCApp.o -MD -MP -MF ".deps/LostIRCApp.Tpo" -c
-o LostIRCApp.o LostIRCApp.cpp; \
	then mv -f ".deps/LostIRCApp.Tpo" ".deps/LostIRCApp.Po"; else rm -f
".deps/LostIRCApp.Tpo"; exit 1; fi
if g++ -DHAVE_CONFIG_H -I. -I. -I../.. -I/usr/include/glibmm-2.4
-I/usr/lib64/glibmm-2.4/include -I/usr/include/sigc++-2.0
-I/usr/lib64/sigc++-2.0/include -I/usr/include/glib-2.0
-I/usr/lib64/glib-2.0/include   -I../../intl    -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m64 -mtune=generic -Wall -MT Parser.o -MD -MP -MF ".deps/Parser.Tpo" -c -o
Parser.o Parser.cpp; \
	then mv -f ".deps/Parser.Tpo" ".deps/Parser.Po"; else rm -f ".deps/Parser.Tpo";
exit 1; fi
Parser.cpp: In member function 'void Parser::TopicTime(const Glib::ustring&)':
Parser.cpp:664: error: 'ctime' is not a member of 'std'
Parser.cpp: In member function 'void Parser::Banlist(const Glib::ustring&)':
Parser.cpp:700: error: 'ctime' is not a member of 'std'
Parser.cpp: In member function 'void Parser::numeric(int, const Glib::ustring&,
const Glib::ustring&, const Glib::ustring&)':
Parser.cpp:879: error: 'ctime' is not a member of 'std'
make[3]: *** [Parser.o] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/builddir/build/BUILD/lostirc-0.4.6/src/libirc'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/builddir/build/BUILD/lostirc-0.4.6/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/lostirc-0.4.6'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.13069 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.13069 (%build)
EXCEPTION: Command failed. See logs for output.
 # bash --login -c 'rpmbuild -bb --target x86_64 --nodeps
//builddir/build/SPECS/lostirc.spec'
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/mock/trace_decorator.py", line 70, in trace
    result = func(*args, **kw)
  File "/usr/lib/python2.4/site-packages/mock/util.py", line 287, in do
    raise mock.exception.Error, ("Command failed. See logs for output.\n # %s" %
(command,), ret)
Error: Command failed. See logs for output.
 # bash --login -c 'rpmbuild -bb --target x86_64 --nodeps
//builddir/build/SPECS/lostirc.spec'
LEAVE do --> EXCEPTION RAISED

Comment 2 Denis Leroy 2008-04-05 12:26:43 EDT
Please see patch in other BZ.


*** This bug has been marked as a duplicate of 440921 ***

Note You need to log in before you can comment on or make changes to this bug.