Bug 434537 - R-RScaLAPACK failed massrebuild attempt for GCC 4.3
R-RScaLAPACK failed massrebuild attempt for GCC 4.3
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: R-RScaLAPACK (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 11:34 EST by Jesse Keating
Modified: 2013-01-09 22:17 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 11:17:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-02-22 11:34:33 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=452303
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Jesse Keating 2008-02-22 17:16:12 EST
Putting this back on the tracker, not sure why it was removed.
Comment 2 John Poelstra 2008-02-29 15:30:27 EST
descendant build failed on x86_64

Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.33539
+ umask 022
+ cd /builddir/build/BUILD
+ cd RScaLAPACK
+ LANG=C
+ export LANG
+ unset DISPLAY
+ rm -rf /var/tmp/R-RScaLAPACK-0.5.1-11.fc9.1-root-mockbuild
+ mkdir -p /var/tmp/R-RScaLAPACK-0.5.1-11.fc9.1-root-mockbuild/usr/lib64/R/library
+ /usr/bin/R CMD INSTALL '--configure-args=CFLAGS='\''-O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m64 -mtune=generic -I/usr/include/lam/ -I/usr/include/lam/64 -L/usr/lib64/lam
-lutil -lmpiblacsCinit -lmpiblacs -llam -llamf77mpi -lmpi -llapack'\''
FFLAGS='\''-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic
-I/usr/include/lam/ -I/usr/include/lam/64 -L/usr/lib64/lam -lutil -llapack
-lmpi'\''' -l
/var/tmp/R-RScaLAPACK-0.5.1-11.fc9.1-root-mockbuild/usr/lib64/R/library RScaLAPACK
* Installing *source* package 'RScaLAPACK' ...
checking for gcc... gcc -m64 -std=gnu99
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc -m64 -std=gnu99 accepts -g... yes
checking for gcc -m64 -std=gnu99 option to accept ANSI C... none needed
checking for pthread_atfork in -lpthread... yes
checking for LAM-MPI... checking LAM-MPI Libraries in the system... checking for
library containing lam_rtrstore... none required
checking for lam_rtrstore in -llam... yes
checking for MPI_Comm_spawn in -lmpi... no
configure: LAM-libmpi.a not found
checking for mpi_comm_create__ in -llamf77mpi... no
configure: LAM-liblamf77mpi.a not found
checking for MPICH... checking for library containing MPI_Comm_spawn... none
required
checking for MPI_Intercomm_merge in -lmpich... no
configure: error: libmpich.a not found
ERROR: configuration failed for package 'RScaLAPACK'
** Removing
'/var/tmp/R-RScaLAPACK-0.5.1-11.fc9.1-root-mockbuild/usr/lib64/R/library/RScaLAPACK'
error: Bad exit status from /var/tmp/rpm-tmp.33539 (%install)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.33539 (%install)
EXCEPTION: Command failed. See logs for output.
 # bash --login -c 'rpmbuild -bb --target x86_64 --nodeps
//builddir/build/SPECS/R-RScaLAPACK.spec'
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/mock/trace_decorator.py", line 70, in trace
    result = func(*args, **kw)
  File "/usr/lib/python2.4/site-packages/mock/util.py", line 287, in do
    raise mock.exception.Error, ("Command failed. See logs for output.\n # %s" %
(command,), ret)
Error: Command failed. See logs for output.
 # bash --login -c 'rpmbuild -bb --target x86_64 --nodeps
//builddir/build/SPECS/R-RScaLAPACK.spec'
LEAVE do --> EXCEPTION RAISED
Comment 3 Tom "spot" Callaway 2008-02-29 15:43:28 EST
Something very very strange is happening here. I cannot reproduce this failure
locally in mock.

This is what seems to be happening:

The R-RScaLAPACK package depends on lam-libs (which put their libraries in
%{_libdir}/lam). lam-libs also includes a %{_libdir}/lam/lam.ld.conf which gets
copied to /etc/ld.so.conf.d/ in %post (via alternatives, and ldconfig is run:

%post libs
alternatives --install %{_sysconfdir}/ld.so.conf.d/mpi%{mode}.conf \
                        mpilibs%{mode} %{_libdir}/lam/lam.ld.conf %{priority}
/sbin/ldconfig

Now, with that said, R-RScaLAPACK is somehow finding liblam, but not libmpi,
even though they're in the same package and same directory. The fact that I
cannot reproduce this failure with make mockbuild worries me.
Comment 4 Tom "spot" Callaway 2008-03-12 11:17:55 EDT
I got this to go through the buildsystem. I have no idea why it wouldn't go
through before. :P

R-RScaLAPACK-0.5.1-11.fc9.2 is in rawhide now.


Note You need to log in before you can comment on or make changes to this bug.