Bug 434543 - Changing icons in Control Center crashes knotify - updates-testing kde 3.5.9
Summary: Changing icons in Control Center crashes knotify - updates-testing kde 3.5.9
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase   
(Show other bugs)
Version: 8
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-22 16:44 UTC by Bartosz Malasiewicz
Modified: 2008-09-06 19:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-06 19:04:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bartosz Malasiewicz 2008-02-22 16:44:49 UTC
Changing icons in kcontrol crashes knotify from kde 3.5.9. I've tested it with
various icon sets and the problem still persists. Arts is enabled and using
alsa. I've remove pulseaudio server since I'm not using it. 
I've following packages installed:
kdeaddons-3.5.9-1.fc8
kdeaddons-extras-3.5.9-1.fc8
kdeartwork-3.5.9-1.fc8
kdeartwork-extras-3.5.9-1.fc8
kdeartwork-icons-3.5.9-1.fc8
kdeartwork-kxs-3.5.9-1.fc8
kdebase-3.5.9-1.fc8
kdebase-devel-3.5.9-1.fc8
kdebase-extras-3.5.9-1.fc8
kdebase-libs-3.5.9-1.fc8
kdebindings-3.5.9-1.fc8
kdebindings-dcopperl-3.5.9-1.fc8
kde-filesystem-4-8.fc8
kdegames-3.5.9-1.fc8
kdegames-libs-3.5.9-1.fc8
kdegraphics-3.5.9-1.fc8
kdegraphics-libs-3.5.9-1.fc8
kde-i18n-Polish-3.5.9-4.fc8
kdelibs-3.5.9-1.fc8
kdelibs-devel-3.5.9-1.fc8
kdemultimedia-3.5.9-1.fc8
kdemultimedia-extras-libs-3.5.9-1.fc8
kdemultimedia-libs-3.5.9-1.fc8
kdenetwork-3.5.9-1.fc8
kdenetwork-libs-3.5.9-1.fc8
kdepim-3.5.9-5.fc8
kdepim-libs-3.5.9-5.fc8
kdesdk-3.5.9-1.fc8
kdesdk-libs-3.5.9-1.fc8
kde-settings-3.5-36.fc8.1
kde-settings-kdm-3.5-36.fc8.1
kdetoys-3.5.9-1.fc8
kdeutils-3.5.9-1.fc8
kdeutils-extras-3.5.9-1.fc8
qt-3.3.8b-2.fc8
arts-1.5.9-1.fc8

Comment 1 Kevin Kofler 2008-02-22 16:50:25 UTC
Have you removed pulseaudio completely, including alsa-plugins-pulseaudio? It's 
a known issue (in alsa-plugins-pulseaudio, nothing we KDE folks can do about 
it) that the PulseAudio ALSA plugin crashes if you uninstall PulseAudio without 
uninstalling the ALSA plugin too.

Comment 2 Rex Dieter 2008-02-22 17:40:19 UTC
Can't reproduce here on any of the f7, f8 boxes I have handy (4), all running
kde-3.5.9.  Switching to/from any of bluecurve, crystalsvg, oxygen, tango
worksforme.

Any additional information you can provide to help reproduce would be immensely
helpful.

Comment 3 Bartosz Malasiewicz 2008-02-22 18:17:36 UTC
Pulseaudio is removed completly. Must be something with my profile. I've tested
it on a clean profile and there is no crash. But I haven't done anything to my
original profile except installing icon sets. Strange.

Comment 4 Bartosz Malasiewicz 2008-02-22 20:17:09 UTC
QObject::disconnect: Unexpected null parameter
QObject::connect: Cannot connect (null)::activePartChanged( KParts::Part * ) to
KHTMLPart::slotActiveFrameChanged( KParts::Part * )
KCrash: Application 'knotify' crashing...
This is what I get in .xsession-errors

Comment 5 Rex Dieter 2008-02-22 20:23:38 UTC
Bartosz, this may well be something better reported upstream to bugs.kde.org
(with more kde developer eyes and feedback).

Comment 6 Rex Dieter 2008-09-06 17:39:41 UTC
Bartosz, ping?

Comment 7 Rex Dieter 2008-09-06 19:04:03 UTC
reporter mailed privately that the issue is now resolved, closing.


Note You need to log in before you can comment on or make changes to this bug.