Bug 434545 - OS crashes when running xserver
OS crashes when running xserver
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-fpit (Show other bugs)
i386 Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-02-22 12:13 EST by Dan Naughton
Modified: 2009-01-09 02:40 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-01-09 02:40:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Log file for xserver (40.61 KB, text/plain)
2008-02-22 12:13 EST, Dan Naughton
no flags Details

  None (edit)
Description Dan Naughton 2008-02-22 12:13:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3

Description of problem:
My system has the AMD Geode LX800 CPU.  I've had no luck getting the xserver running.

Graphical install fails - had to use text mode only
Xorg -configure fails  "Missing output drivers.  Configuration failed."
ddprobe fails - no monitors detected

When i configure the xserver with the amd-drv.so  "amd" driver, the computer crashes (no network, keyboard, screen - looks like a hard failure).  I even used the xorg.conf_lx sample configuration from AMD, but the result was the same - the computer crashed.

The log files don't indicate anything:
(II) LoadModule: "pcidata"
(II) Loading /usr/lib/xorg/modules//libpcidata.so
(II) Module pcidata: vendor="X.Org Foundation"
        compiled for 1.3.0, module version = 1.0.0
- it looks like the computer died right here.

It might not be the amd driver, but when I try the VESA driver, it still doesn't work, but the computer is still partially alive (display shut off, but network still up)

I tried the amd driver in fedora testing, but it didn't make any difference.  Other "distros" - this live usbkey gparted version got the xserver up right away with xfce on it.  Windows XP and CE runs on the hardware.  

Version-Release number of selected component (if applicable):
kernel- xorg-x11-drv-amd-0.0-22.20070625.fc8 xorg-x11-server-Xorg- 

How reproducible:

Steps to Reproduce:
1.boot computers
3.computer dies.

Actual Results:
Computer locks up - no display, no keyboard (num lock key LED goes off), network stops responding

Expected Results:
Xserver starts up.

Additional info:
Comment 1 Dan Naughton 2008-02-22 12:13:56 EST
Created attachment 295656 [details]
Log file for xserver
Comment 2 Dan Naughton 2008-02-22 12:18:11 EST
I don't think I got the last part of the log file correct:

(WW) AMD(0): xf86UnMapVidMem: cannot find region for [0xb3dab000,0x3e00000]
Comment 3 Dan Naughton 2008-03-02 22:32:27 EST
I got some information back on the xorg mailing list from someone way more
knowledgeable that me.  Apparently there is a bug in the xserver for Geode
motherboard that use GSW VGA BIOS.  There's more information on this one here:


I hope this helps.
Comment 4 Bug Zapper 2008-11-26 04:55:05 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 5 Bug Zapper 2009-01-09 02:40:42 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.