Bug 434564 - CRM #1799024 net-snmp spec file does not have require net-snmp-libs
CRM #1799024 net-snmp spec file does not have require net-snmp-libs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: net-snmp (Show other bugs)
4.6
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jan Safranek
:
Depends On:
Blocks: 391511 434746
  Show dependency treegraph
 
Reported: 2008-02-22 14:32 EST by Alan Matsuoka
Modified: 2010-10-22 18:43 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0700
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:50:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alan Matsuoka 2008-02-22 14:32:42 EST
Description of problem:

net-snmp requires net-snmp-libs to work, but the SPEC file doesn't have the
below requirement specification in it to enforce it.

Requires: %{name}-libs = %{version}-%{release}

The end result is that, if a customer runs "up2date net-snmp", it would update
the net-snmp package to the latest version without updating the net-snmp-libs
package to the latest version which would cause snmp service to fail.

How reproducible:

Always.

Steps to Reproduce:

- Take an RHEL4 system.
- Do "rpm -e snmp snmp-libs --nodeps"
- Download the net-snmp and net-snmp-libs packages from
http://porkchop.redhat.com/brewroot/packages/net-snmp/5.1.2/11.el4_6 .11.1/ and
install it using "rpm -ivh net-snmp*" command.
- Make sure that snmpd starts successfully.
- Run "up2date net-snmp". It would only update net-snmp without updating
net-snmp-libs
- Restart snmpd service. It should show "OK", but the service would actually
fail to start.

Actual results:

- net-snmp does not require net-snmp-libs-{version}-{release}

Expected results:

It should be dependent on net-snmp-libs

Additional info:

Attaching patch for RHEL4 and RHEL5 which can be applied for the SPEC file.

One reference - https://bugzilla. redhat.com/show_bug.cgi?id=139740

Bugzilla filed for RHEL4 and fixed in rawhide. I would request to open separate
bugzillas for RHEL4 and RHEL5. Let me know if you want me to clone this IT for
RHEL5.

Regards,

--Sadique
Comment 3 RHEL Product and Program Management 2008-02-25 03:38:08 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 errata-xmlrpc 2008-07-24 15:50:41 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0700.html

Note You need to log in before you can comment on or make changes to this bug.