Bug 43459 - large number of files, 'file open error'
large number of files, 'file open error'
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
: 54286 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-04 23:20 EDT by Beth Miner
Modified: 2007-04-18 12:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-16 12:00:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Beth Miner 2001-06-04 23:20:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
Occasionally lpr will stop sending spool files to the printer. if you spool
up 100 files or so you can see it many times.. i just saw it five times.
Anyway, it almost looks to my untrained eye like a race condition.. in the
lpr log you get something like..

2001-06-04-22:06:30.777 yucca1 [11632] (Server)  hplj2200: Open_gdbm:
gdbm_lock fd 87
2001-06-04-22:06:30.777 yucca1 [11632] (Server)  hplj2200: Open_gdbm:
locking 87
2001-06-04-22:06:30.778 yucca1 [11632] (Server)  hplj2200: setstatus: msg
'hplj2200: Open_dgbm: open of DB file 'db.hplj2200' failed, File open
error'
2001-06-04-22:06:30.778 yucca1 [11632] (Server)  (ERR) hplj2200: Open_dgbm:
open of DB file 'db.hplj2200' failed, File open error
2001-06-04-22:06:30.781 yucca1 [11632] (Server)  hplj2200: cleanup: done,
exit(33)

If you restart lpd it will continue printing usually. I'm not sure how to
dig around for  deeper information, so that's all i could find so far. lpr
was called from a bash command like 
for i in *.2 ; do groff -man $i | lpr ; done 
which put 120 files in the queue rather quickly. I haven't tried it slowly
yet cause i'm not very patient..

How reproducible:
Always

Steps to Reproduce:
1. submit a bunch of jobs to lpr
2. sit back and watch the log file
3. There is no step three.
	

Actual Results:  2001-06-04-22:06:30.777 yucca1 [11632] (Server)  hplj2200:
Open_gdbm: gdbm_lock fd 87
2001-06-04-22:06:30.777 yucca1 [11632] (Server)  hplj2200: Open_gdbm:
locking 87
2001-06-04-22:06:30.778 yucca1 [11632] (Server)  hplj2200: setstatus: msg
'hplj2200: Open_dgbm: open of DB file 'db.hplj2200' failed, File open
error'
2001-06-04-22:06:30.778 yucca1 [11632] (Server)  (ERR) hplj2200: Open_dgbm:
open of DB file 'db.hplj2200' failed, File open error
2001-06-04-22:06:30.781 yucca1 [11632] (Server)  hplj2200: cleanup: done,
exit(33)


Expected Results:  It should have kept on printing.. should i be filling
these fields in still?

Additional info: Uhm... none, really.
Comment 1 Yong Chen 2001-08-07 11:11:20 EDT
I am having the exact same problem.  Hope that we can get a fix ASAP.
Comment 2 Bob Licitra 2001-12-05 19:29:11 EST
I have the same problem with 2.4.3-6smp on a 2-processor i686
(Dell PowerEdge 2500 running Redhat 7.1)
Comment 3 Tim Waugh 2002-01-10 06:28:13 EST
*** Bug 54286 has been marked as a duplicate of this bug. ***
Comment 4 Tim Waugh 2002-02-15 11:57:28 EST
I haven't been able to duplicate this with our current build, so I think it's
fixed in the latest package.

I'll see if I can track down exactly where the fix is.
Comment 5 Tim Waugh 2002-03-05 12:33:03 EST
Has anyone seen this problem on Red Hat Linux 7.2, or is it just 7.1?
Comment 6 Tim Waugh 2005-09-16 12:00:07 EDT
We no longer ship LPRng.

Note You need to log in before you can comment on or make changes to this bug.