Bug 434595 - make dm-log usable by modules other than dm-mirror
make dm-log usable by modules other than dm-mirror
Status: CLOSED DUPLICATE of bug 429337
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Jeffrey Moyer
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-22 18:28 EST by Jeffrey Moyer
Modified: 2008-04-01 14:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-01 14:10:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Make dm-log.c a self-contained module (3.37 KB, patch)
2008-02-22 18:28 EST, Jeffrey Moyer
no flags Details | Diff
make the dirty log code a standalone module (5.01 KB, patch)
2008-02-26 15:20 EST, Jeffrey Moyer
no flags Details | Diff

  None (edit)
Description Jeffrey Moyer 2008-02-22 18:28:04 EST
Description of problem:
The dm-replicator target uses interfaces defined in dm-log.  The way it is
currently built, this will cause problems.  dm-log should be its own module,
upon which both dm-mirror and dm-replicator can depend.

Version-Release number of selected component (if applicable):
2.6.18-82.el5
Comment 1 Jeffrey Moyer 2008-02-22 18:28:05 EST
Created attachment 295689 [details]
Make dm-log.c a self-contained module
Comment 2 Jeffrey Moyer 2008-02-26 15:20:47 EST
Created attachment 295989 [details]
make the dirty log code a standalone module

This version fixes up printk's to show dirty log instead of mirror log.
Comment 3 RHEL Product and Program Management 2008-02-27 09:59:01 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 11 Jeffrey Moyer 2008-04-01 14:10:22 EDT

*** This bug has been marked as a duplicate of 429337 ***

Note You need to log in before you can comment on or make changes to this bug.