Bug 434596 - Include device mapper headers in the kernel-devel packages
Include device mapper headers in the kernel-devel packages
Status: CLOSED DUPLICATE of bug 429337
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Jeffrey Moyer
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-22 18:34 EST by Jeffrey Moyer
Modified: 2008-04-01 14:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-01 14:11:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Include device mapper header files in the -devel packages (862 bytes, patch)
2008-02-22 18:34 EST, Jeffrey Moyer
no flags Details | Diff

  None (edit)
Description Jeffrey Moyer 2008-02-22 18:34:32 EST
Description of problem:
We want to ship dm-replicator-kmod as a separate module/package, and so it must
build outside of the kernel tree.  Currently, this is not possible, since
several device mapper header files live in drivers/md.  This patch copies those
files into the tree created for the -devel packages.

Version-Release number of selected component (if applicable):
2.6.18-82.el5
Comment 1 Jeffrey Moyer 2008-02-22 18:34:32 EST
Created attachment 295690 [details]
Include device mapper header files in the -devel packages
Comment 2 RHEL Product and Program Management 2008-02-27 09:58:58 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Alasdair Kergon 2008-03-02 19:58:12 EST
To support out-of-tree builds of dm modules, we need to sort out a cleaned-up
interface and propose patches upstream to place suitable headers in the proper
include directory.  In other words some of the things in .h files under
drivers/md should be replaced by things in include/linux.
Comment 6 Alasdair Kergon 2008-03-02 20:13:01 EST
I don't just want the existing .h files moving because they are rather messy,
and not everything in there should be published for external use.  The logical
groups of functions you need should be pulled out, documented very briefly, and
put into new header files in include/linux.  The upstream version of this may
also include some minor renaming and/or function/parameter changes.
Comment 8 Jeffrey Moyer 2008-04-01 14:11:28 EDT

*** This bug has been marked as a duplicate of 429337 ***

Note You need to log in before you can comment on or make changes to this bug.