Bug 434619 - mesa-libOSMesa: Shared library is not a symlink
mesa-libOSMesa: Shared library is not a symlink
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-23 08:51 EST by Horst H. von Brand
Modified: 2008-03-04 11:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-03 00:32:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2008-02-23 08:51:00 EST
Description of problem:
When updating I get:

  Updating  : mesa-libOSMesa               ##################### [ 83/913] 
  /sbin/ldconfig: /usr/lib/libOSMesa32.so.6 is not a symbolic link

Version-Release number of selected component (if applicable):
mesa-libOSMesa-7.1-0.16.fc9.i386

How reproducible:
Each time ldconfig runs ;-)


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Note that mesa-libOSMesa is not in the bugzilla package list
Comment 1 Michal Jaegermann 2008-02-23 11:36:36 EST
In case of x86_64 there are complaints about
/usr/lib64/libOSMesa16.so.6
/usr/lib64/libOSMesa32.so.6
/usr/lib64/libOSMesa.so.6
It looks like that ldconfig has indeed reasons to be unhappy.
Comment 2 Charles R. Anderson 2008-02-24 14:56:57 EST
I saw the same thing during the yum update process when ldconfig was run
automatically in %post scripts etc., but now it doesn't happen anymore with
manual ldconfig runs:

# uname -m
x86_64

# ldconfig -v 2>&1 | grep -i libOSMesa
	libOSMesa32.so.6 -> libOSMesa32.so.6
	libOSMesa.so.6 -> libOSMesa.so.6
	libOSMesa16.so.6 -> libOSMesa16.so.6

# rpm -V mesa-libOSMesa-7.1-0.16.fc9.x86_64
# ls -l /usr/lib64/libOSMesa*
-rwxr-xr-x 1 root root 2418928 2008-02-21 15:30 /usr/lib64/libOSMesa16.so.6
-rwxr-xr-x 1 root root 2390544 2008-02-21 15:30 /usr/lib64/libOSMesa32.so.6
-rwxr-xr-x 1 root root 2456368 2008-02-21 15:30 /usr/lib64/libOSMesa.so.6
Comment 3 Adam Jackson 2008-03-04 11:38:15 EST
Fixed in rawhide as of mesa 7.1-0.19 or so.

Note You need to log in before you can comment on or make changes to this bug.