Bug 434625 - NetworkManager dhcp setup not robust enough
NetworkManager dhcp setup not robust enough
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: NetworkManager (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: Dan Williams
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-23 10:43 EST by Daniel Riek
Modified: 2013-02-19 00:21 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-19 00:21:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Riek 2008-02-23 10:43:35 EST
Description of problem:
Many ill-configured dhcp server e.g. in hotel-room access points provide gateway
ip addresses outside of the local net or simply wrong netmasks (such as
255.255.255.255). In that case a RHEL client connecting using NetworkManager
will not set up any routes and thus will not be able to connect to the network,
although an explicit and correct ip address for the router was given and it
actually would be reachable with a host-route.

Version-Release number of selected component (if applicable):
NetworkManager-0.6.4-7.el5

How reproducible:
Set up a dhcp server with a wrong netmask for the local network, such as
255.255.255.255, so that the default gateway's ip address is outside of the
network assigned to the local system.

Steps to Reproduce:
1. Connect to the network with the so mis-configured dhcp-server
2. run ip route
  
Actual results:
No routes are set

Expected results:
A host route to the gateway should be set regardless of the mis-configuration.

Additional info:
/sbin/dhclient-script has provisions for this case and correctly sets a
host-route to the gateway if run manually in the very same configuration.

Justification:
The impact of this problem is that normal users running RHEL without technical
expertise often can not connect to the Internet in hotels, etc. Windows for
example is more robust and handles the situation gracefully.
Comment 1 Dan Williams 2008-02-29 18:17:37 EST
So if you want to patch it, what I told you was for 0.7.  For RHEL5, you'll
probably want to look at src/NetworkManagerSystem.c,
nm_system_device_set_from_ip4_config().
Comment 2 RHEL Product and Program Management 2008-06-02 16:17:12 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 16 Dan Williams 2008-12-09 17:37:50 EST
NetworkManager-0.7.0-2.el5
Comment 17 Dan Williams 2008-12-09 17:38:10 EST
grr, not actually modified yet.
Comment 18 Jonathan Blandford 2008-12-10 16:05:38 EST
Still not sure what's different with the kernels, and its too late in the cycle to fix.  Moving to 5.4.
Comment 22 Zack Cerza 2009-06-10 15:07:54 EDT
dhcpd isn't letting me configure it in this way. Can we get an example configuration for testing?
Comment 23 Zack Cerza 2009-06-11 13:00:52 EDT
Looks like this is actually being punted to 5.5.
Comment 29 RHEL Product and Program Management 2010-08-09 14:59:10 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 30 Dan Williams 2013-02-19 00:21:53 EST
Not going to get fixed on RHEL5, but it works on RHEL6 and Fedora.

Note You need to log in before you can comment on or make changes to this bug.