Bug 434628 - Bugzilla's CSS lacks textarea/select/input color
Bugzilla's CSS lacks textarea/select/input color
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: User Interface (Show other bugs)
3.2
All Linux
low Severity high (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-23 11:12 EST by Leszek Matok
Modified: 2013-06-23 22:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-16 13:18:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is how it looks. (104.59 KB, image/png)
2008-02-23 11:12 EST, Leszek Matok
no flags Details

  None (edit)
Description Leszek Matok 2008-02-23 11:12:43 EST
I'm attaching a screen shot demonstrating how BZ looks like under Fedora 8 with
the "Darklooks" GTK+ theme selected. As you'll see, the style sheet:
- sets border and background, but doesn't set color (foreground color) of
"input" class, that's why one-line text inputs and all the buttons are almost
unreadable (but I can imagine what happens with some other system color schemes)
- doesn't touch "textareas" and "selects" at all, so they don't fit well into
the whole, but at least they're readable.

The "Goto bug #" (never mind the typo, it should read "go to", right?) form has
grey background, and it's even more unreadable than the yellowish inputs that
I've fit in the screenshot.

If you don't want to mess with all the widgets, that's fine (although it doesn't
look very professional). But if you change some widget's style, don't stop in
the middle. I'm asking for setting the foreground of widgets that have
background set, because you can't assume people have black as the default color
everywhere.
Comment 1 Leszek Matok 2008-02-23 11:12:43 EST
Created attachment 295704 [details]
This is how it looks.
Comment 2 Leszek Matok 2008-08-05 13:13:08 EDT
Well, with BZ 3.2 the yellow background disappeared. Maybe the black text boxes don't look great on white pages, but at least it's readable now.
Comment 3 David Lawrence 2008-09-16 12:56:00 EDT
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.
Comment 4 Leszek Matok 2008-09-16 13:14:25 EDT
David,

Just as I wrote in comment #2, the background is not being set anymore. So now, instead of grey text on yellow background, I get grey text on black background everywhere (which is the default in this color scheme). I don't think this is really on purpose - I suppose someone wanted to have black text on white background (which is the default in the default color scheme, which most people stick to).

So now it's readable and I don't have any issue with usability of the site.

Just thought someone's sens of aesthetics might be hurt :)
Comment 5 David Lawrence 2008-09-16 13:18:56 EDT
Thanks for verifying this is fixed. Closing.

Dave

Note You need to log in before you can comment on or make changes to this bug.