Bug 434629 - Realtek RTL8111/8168B ethernet not working in kernel >=2.6.24 [Regression
Realtek RTL8111/8168B ethernet not working in kernel >=2.6.24 [Regression
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-23 11:14 EST by Nicolò
Modified: 2008-03-25 13:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-25 13:30:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ethtool output (1.73 KB, text/plain)
2008-02-29 10:25 EST, Nicolò
no flags Details

  None (edit)
Description Nicolò 2008-02-23 11:14:27 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Nicolò 2008-02-23 11:22:12 EST
Very sorry hit enter by mistake...

Description of problem:
My gigabit ethernet card used to work with kernel before 2.6.24, now it doesn't

Additional info:
lspci -v:
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI
Express Gigabit Ethernet controller (rev 01)
	Subsystem: ASUSTeK Computer Inc. Unknown device 11f5
	Flags: bus master, fast devsel, latency 0, IRQ 11
	I/O ports at c800 [size=256]
	Memory at dcfff000 (64-bit, non-prefetchable) [size=4K]
	Expansion ROM at dcfe0000 [disabled] [size=64K]
	Capabilities: [40] Power Management version 2
	Capabilities: [48] Vital Product Data <?>
	Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/1 Enable-
	Capabilities: [60] Express Endpoint, MSI 00
	Capabilities: [84] Vendor Specific Information <?>
	Kernel driver in use: r8169

relevant dmesg:
...
eth0: RTL8168b/8111b at 0xffffc2000001e000, 00:18:f3:32:78:91, XID 38000000 IRQ 11
...
r8169: eth0: link up

Which is exactly identical to what it said in 2.6.23...

Comment 2 Vaclav "sHINOBI" Misek 2008-02-26 16:18:50 EST
Can you post the latest kernel version you have tried? Also please send output
from ifconfig, ethtool.
If you have time and can still reproduce the bug with the latest kernel version,
please read http://fedoraproject.org/wiki/BugsAndFeatureRequests and add a more
precise description to this bug.
Comment 3 Nicolò 2008-02-29 10:25:52 EST
Created attachment 296365 [details]
ethtool output

Please forgive me for the lack of detail in initial report, I had no time to
deeply test anything.

- Latest kernel I've tried is 2.6.24-2.fc9 (from the livecd) both 32 and 64
bits

attached ethtool
Comment 4 Vaclav "sHINOBI" Misek 2008-02-29 16:56:41 EST
I suppose, you are using DHCP right? Please try to assign a fixed IP address for
adapter and try it again. Also try to use the latest kernel, as rawhide is a
moving target and it can be broken in some older versions :-). I have similar
network card in my ntb and it works correctly with the last kernels.
Comment 5 Nicolò 2008-03-01 06:29:41 EST
Yes, I was using DHCP. I've also tried static IP, but the results are the same 
(except tha pinging the router makes its led to blink, but still "Destination 
host Unreachable")
Latest fedora kernel does not boot, sorry I cannot try it...
Anyway, A friend of mine which has my same notebook (Asus A6T) and uses Gentoo 
told me that he is having the same problem, from 2.6.24 to whatever is the 
latest version of vanilla-sources (2.6.25.?)...
If it's really the same problem, then it's not fedora specific, should I file 
a bug at kernel.org?
Comment 6 Vaclav "sHINOBI" Misek 2008-03-02 08:55:55 EST
Oh I nearly forgot. Is there anything interesting in /var/log/messages? I
noticed also some similar bugreport on debian list with the same notebook type.
Please also try to boot with acpi=off if that works, narrowing down by trying
pci=noacpi instead. You should also try it with the latest kernel, it should
make them bootable for you again.
Comment 7 Nicolò 2008-03-02 17:14:42 EST
Argh, I remember there are many errors regarding many different, and I hope 
unrelated problems, including at least the following (quoting from memory, 
I'll send precise output ASAP, away from home now...)
-various kinds of ACPI errors, both with acpi=off and pci=noacpi
-various other APIC errors: I have to use "noapic" to get anything below 
2.6.23 to boot (known problem for this laptop... :( ), 2.6.24 on the other 
hand, boots even without this... hmmm...
-something being not E820-reserved
-tons of repeated lines of complaints about ata1, which I will do you the 
favour of removing, because they make the rest unreadable

In spite of all the above, my machine worked *just fine* until now...
Comment 8 Jay Chandler 2008-03-10 18:47:11 EDT
I can confirm that the kernel upgrade had the same effect on my system; works
correctly under the prior kernel, the latest upgrade broke it.  Let me know what
additional steps you'd like me to take; DHCP is broken, haven't attempted a
static assignment yet but can.
Comment 9 Nicolò 2008-03-25 12:34:18 EDT
WORKS, at least for me,
F9-Beta, 2.6.25-0.121.rc5.git4.fc9 (why don't you use simpler version 
numbers? ;-)
Comment 10 Vaclav "sHINOBI" Misek 2008-03-25 13:30:28 EDT
Great, I'm closing it with rawhide resolution.

Note You need to log in before you can comment on or make changes to this bug.