Bug 434659 - On black background, an inverse-video at sign doesn't show
On black background, an inverse-video at sign doesn't show
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: Terminal (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-23 20:49 EST by Horst H. von Brand
Modified: 2008-04-08 23:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-08 23:53:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2008-02-23 20:49:47 EST
Description of problem:
I'm addicted to crawl http://sourceforge.net/projects/crawl-ref, a roguelike
game. As currently Gnome is broken beyond usage, I'm using XFCE. And in Terminal
the at sign representing the character doesn't show. In an xterm or
gnome-terminal it works fine.

crawl uses a black background, and uses curses.

Version-Release number of selected component (if applicable):
Terminal-0.2.8-3.fc9.i386
ncurses-libs-5.6-15.20080112.fc9.i386 (crawl uses ncursesw)


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Should I attach the executable, or the source tarball, for the game?
Comment 1 Kevin Fenzi 2008-02-23 23:00:11 EST
Interesting, as both Terminal and gnome-terminal use the 'vte' package for their
backends. 

You have a black background, what is your cusor color set to? Text color?
If you change the preferences->advanced-> $TERM from 'xterm' to 'vt100' does it
work?

Comment 2 Horst H. von Brand 2008-02-24 11:18:03 EST
Setting it to vt100 and resetting the Terminal gives an at-sign. Cursor and text
are black, background white.

I just tried side by side with gnome-terminal, there it works
Comment 3 Horst H. von Brand 2008-02-24 11:20:21 EST
Sorry, no. I did X in the game (shows an overview of the dungeon level), there
the at sign shows, going back to the "normal" view and the at is gone again.
Shows just as a black space (on black).
Comment 4 Kevin Fenzi 2008-03-01 21:12:41 EST
I'm really not sure how to track this down further... 

Would you be willing to file an upstream bug? 
Or if you prefer I can file one for you? 
Comment 5 Horst H. von Brand 2008-03-05 16:41:01 EST
Sorry, I was away (from this bug).

Where should I file?
Comment 6 Kevin Fenzi 2008-03-05 19:40:54 EST
http://bugzilla.xfce.org/ 

Or if you don't want to deal with another account there I can file it... 
Just let me know if you would like me to do so. 
Comment 7 Horst H. von Brand 2008-03-06 15:13:38 EST
Reported as http://bugzilla.xfce.org/show_bug.cgi?id=3925.

Strangely, today (no changes in Terminal, ncurses-libs!) the game shows as black
characters (only, no colors for potions or others!) on white. I hacked together
one of the ncurses examples to compile, that one I attached upstream.
Comment 8 Kevin Fenzi 2008-03-06 16:06:55 EST
Shall we keep this open as a reminder in case upstream has a patch we need to
apply? Or go ahead and close it now?

I added myself to CC on the upstream bug. 

If there is anything further I can do, please let me know. 
Comment 9 Horst H. von Brand 2008-03-07 07:02:06 EST
I'm just the bug reporter here, whoever is the owner of the package should make
that call.

Thanks!
Comment 10 Kevin Fenzi 2008-04-08 23:53:08 EDT
Well, since I am CC'ed on the upstream bug I should be able to see when/if there
is activity on it, so I will go ahead and close this UPSTREAM. 
Feel free to reopen or file a new bug if you spot anything further. 

Note You need to log in before you can comment on or make changes to this bug.