Bug 434662 - default firewall prevents odccm from working
default firewall prevents odccm from working
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: odccm (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-23 22:37 EST by phil
Modified: 2008-06-21 18:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-18 03:14:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description phil 2008-02-23 22:37:31 EST
Description of problem:
The odccm package does not set the firewall rules to allow it to access
connected Windows Mobile devices nor does it add odccm to the list of services
in the firewall configuration tool.

Version-Release number of selected component (if applicable):
odccm-0.11-1.fc8.x86_64.rpm

Steps to Reproduce:
1. yum install odccm
2. plug in a Windows Mobile Device
3. odccm will show that it gets the message from HAL about the pda interface but
nothing else happens.
4. Do 2 and 3 with the firewall disabled.  It works.
Comment 1 Andreas Bierfert 2008-06-18 03:14:25 EDT
Opening up the firewall by default is nothing a package should do.
system-config-firewall to my knowledge does not have a way for services to add
themselves to the list of services so if you really think this should be there
fill a feature request with the firewall tool.
Comment 2 phil 2008-06-21 18:46:08 EDT
I don't disagree with you.  Opening holes in the firewall is a problem.

However, if we want Windows Mobile devices to work with Fedora "out of the box."
something needs to be done. Since odccm cannot work without those ports open
there needs to be a way to inform the user what needs to be done.  Otherwise,
odccm is useless whenever the default firewall is installed and enabled.

Note You need to log in before you can comment on or make changes to this bug.