Bug 434705 - unreadable fonts in hebrew ui
unreadable fonts in hebrew ui
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-24 13:25 EST by Nadav Kavalerchik
Modified: 2008-03-04 14:31 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-04 11:06:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nadav Kavalerchik 2008-02-24 13:25:24 EST
Description of problem:
i switched from english ui to hebrew ui and all the fonts turned into empty
boxes (seems like hebrew glyphs are missing in the font, which one i do not know)

i use system fonts in the OO preferences and i use kde as main desktop although
i have gnome installed and configured too.

i have checked gnome-control-center >> appearance and kde control center >>
fonts to see that the ui fonts are readable in hebrew and they are.

this happened after a complete system upgrade from fc6 straight to fc8
(which worked quite smoothly :-) other then this issue )

Version-Release number of selected component (if applicable):
2.3.0-6-11 fc8

How reproducible:
change ui to hebrew

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
see hebrew font glyphs

Additional info:
i know some fonts (liberation) does not have hebrew glyphs so maybe it's one of
them. i wonder how do i change the ui font ?
Comment 1 Caolan McNamara 2008-02-25 04:39:32 EST
a) do you have openoffice.org-langpack-he_IL installed ?
b) do you have fonts-hebrew installed ?
c) what is the name of the font listed for "Application Font" in the
control-centers,
d) and finally what is the locale, and what is listed if you use fc-match on the
above font name, e.g.
> echo $LANG
> fc-match "Sans"

e.g. it works for me in that I have recognizable hebrew in the OOo UI with
openoffice.org-langpack-he_IL installed. It requires fonts-hebrew and that
ensures that "culmus-fonts" is installed which provides some hebrew fonts. 

My Application font is just "Sans" and fc-match "Sans" where LANG=he_IL.UTF-8
states "David CLM".

So if you have problems I'd probably need to figure out what font is set as the
desktop application font and what real font is suggested by fontconfig for apps
like OOo to use, which fc-match should give us
Comment 2 Nadav Kavalerchik 2008-02-25 17:54:24 EST
a) do you have openoffice.org-langpack-he_IL installed ?
YES
b) do you have fonts-hebrew installed ?
YES
c) what is the name of the font listed for "Application Font" in the
control-centers,
"Sans"
d) and finally what is the locale, and what is listed if you use fc-match on the
fc-match "Sans"
DejaVuSans.ttf: "DejaVu Sans" "Book"
(it does have hebrew glyphs ! it is a great font btw.)
locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

BUT...
i use LANG=he_IL.UTF-8 to start openoffice.org

checking the /usr/share/fonts folder, i found out that the Culmus fonts are not
there !!! the package is installed but no fonts :-)
i removed the package and installed it again. which (btw) change the folders a
little bit, never mind.
so i have all the culmus fonts. but still did not solve this issue.
i looked into debains parallel package and it included
/etc/fonts/conf.d/65-culmus.conf which are nice and we should add them too !
but still... issue not solved.

and while i am writing this reply,i found out that using Deja Vu Sans in Writer
is producing "empty boxes" instead of hebrew glyphs too (not just the UI !)

and i found out that Deja Vu Sans is replaced by Deja Vu LGC Sans which does not
have hebrew glyphs !!! although fc-match does not (clearly) report so :-(

removing Legacy Deja Vu is not possible via Yum since it forces me to remove
several important packages :-(

==== yum debug:
Packages to remove
00:39:37 :  ---> dejavu-lgc-fonts - 2.19-1.noarch
00:39:37 : Preparing for install/remove/update
00:39:37 : --> Preparing for remove
00:39:38 : --> Running transaction check
00:39:38 : ---> Package dejavu-lgc-fonts.noarch 0:2.19-1 set to be erased
00:39:38 : --> Processing Dependency: dejavu-lgc-fonts for package: vlc
00:39:38 : --> Processing Dependency: dejavu-lgc-fonts for package: rrdtool
00:39:38 : --> Running transaction check
00:39:38 : ---> Package rrdtool.i386 0:1.3-0.6.beta3.fc8 set to be erased
00:39:38 : --> Processing Dependency: librrd.so.2 for package: rrdtool-php
00:39:38 : --> Processing Dependency: librrd.so.2 for package: rrdtool-devel
00:39:38 : --> Processing Dependency: librrd.so.2 for package: rrdtool-perl
00:39:38 : --> Processing Dependency: librrd_th.so.2 for package: rrdtool-devel
00:39:38 : --> Processing Dependency: rrdtool = 1.3-0.6.beta3.fc8 for package:
rrdtool-php
00:39:38 : --> Processing Dependency: rrdtool for package: cacti
00:39:38 : --> Processing Dependency: rrdtool = 1.3-0.6.beta3.fc8 for package:
rrdtool-devel
00:39:38 : --> Processing Dependency: rrdtool = 1.3-0.6.beta3.fc8 for package:
rrdtool-perl
00:39:38 : ---> Package vlc.i386 0:0.8.6d-3.lvn8 set to be erased
00:39:38 : --> Processing Dependency: vlc = 0.8.6d-3.lvn8 for package: mozilla-vlc
00:39:38 : --> Running transaction check
00:39:38 : ---> Package rrdtool-perl.i386 0:1.3-0.6.beta3.fc8 set to be erased
00:39:38 : --> Processing Dependency: perl(RRDs) for package: perl-RRD-Simple
00:39:38 : ---> Package mozilla-vlc.i386 0:0.8.6d-3.lvn8 set to be erased
00:39:38 : ---> Package cacti.noarch 0:0.8.7b-1.fc8 set to be erased
00:39:38 : ---> Package rrdtool-php.i386 0:1.3-0.6.beta3.fc8 set to be erased
00:39:38 : ---> Package rrdtool-devel.i386 0:1.3-0.6.beta3.fc8 set to be erased
00:39:38 : --> Running transaction check
00:39:38 : ---> Package perl-RRD-Simple.noarch 0:1.43-1.fc7 set to be erased
00:39:44 : --> Finished Dependency Resolution
====

so i can either change the font-config rules or move the font folder
(for now, i just moved the /usr/share/fonts/dejavu-lgc somewhere safe)
and this issue was _SOLVED_ :-)

i will dig into the Deja Vu LGC fc rules and fix so it could live nicely with
Deja Vu and post it back here later ;-)
Comment 3 Caolan McNamara 2008-02-25 18:09:12 EST
What does fc-match Sans say *after* e.g. export LANG=he_IL.UTF-8 i.e. what is
the substitution from the perspective of the OOo that you run under that locale ?
Comment 4 Nadav Kavalerchik 2008-02-25 18:59:36 EST
[root@server ~]# export LANG=he_IL.UTF-8
[root@server ~]# fc-match "Sans"
DejaVuSans.ttf: "DejaVu Sans" "Book"

i've installed (moved back the Deja Vu LGC) and then
[root@server ~]# fc-match "Sans"
DejaVuSans.ttf: "DejaVu Sans" "Book"

i started openoffice.org and it works fine too :-) even with the Deja Vu LGC
when i use it for hebrew it gets hebrew glyphs from some font (i do not know
from which one )

>> what is the substitution from the perspective of the OOo that you run under
that locale ?
what do you mean ? the font-config rules for that language/encoding ?
Comment 5 Caolan McNamara 2008-02-26 05:21:01 EST
a) "what is the substitution from the ...", that's ok now. That's answered by
the fc-match "Sans" from a he_IL.UTF-8 LANG environment.

b) I installed dejavu-fonts in addition to the dejavu-lgc-fonts on my stock F8
box and now also have
fc-match "Sans" as
DejaVuSans.ttf: "DejaVu Sans" "Book"
in LANG=he_IL.UTF-8

starting OOo still shows no problems for me in that locale with those fonts
installed.

What's your status now, you say "i started OOo and it works fine too" do you
still have a problem at the moment ? Or has it "gone away" after fixing the
missing culmus fonts contents and moving the devavu lgc fonts out and back in ?

A possibility was/is an out of sync fontconfig cache wrt the installed fonts
which is resolved now after fc-cache got run during that process.
Comment 6 Nadav Kavalerchik 2008-02-26 13:57:25 EST
problem gone away :-)
OOo works fine :-)

i have issued "fc-cache -f" several times throughout the process so i am quite
sure the cache was/is ok and i am more inclined to think that the font
substitution rules are in need for fix.

and i also think that the missing culmus fonts have nothing to do with it.

i guess, i will go over them at the weekend.
Comment 7 Caolan McNamara 2008-03-04 11:06:47 EST
I think we'll close this out, if there's still a problem somewhere I don't think
it lies directly in OOo itself.
Comment 8 Nadav Kavalerchik 2008-03-04 14:31:41 EST
i agree with the last remark (comment #7)

i think/guess font-config rules got confused over the upgrade from fc6-->fc8
and i think that with a fresh install this would not have happened.
and that OOo is ok.

Note You need to log in before you can comment on or make changes to this bug.