This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 434716 - FC9-Alpha upgrade from FC6 does not mount /boot partition
FC9-Alpha upgrade from FC6 does not mount /boot partition
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-02-24 17:30 EST by Trevin Beattie
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-16 13:32:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Trevin Beattie 2008-02-24 17:30:57 EST
Description of problem:
I'm testing an upgrade from FC6 to FC9 on a VMware machine.  After installing
FC6 and customizing several packages and system settings, I rebooting with the
FC9a DVD and requested an upgrade to the existing installation.  The upgrade
process seemed to proceed normally.

When I rebooted, the system started up with the FC6 kernel instead of the FC9
kernel and a large number of system services failed to start.

Further examination of the issue showed that the /boot partition was missing
from /etc/fstab, and appears not to have been mounted during the upgrade
process.  The /boot directory on the root partition contains the new kernel
image but not the old one nor grub.conf; if I mount the /boot partition, I see
it contains the old kernel image and grub.conf but the new kernel is not present.

Here are the complete contents of the /boot partition (/dev/sda1):
boot:
System.map-2.6.18-1.2798.fc6  lost+found
config-2.6.18-1.2798.fc6      symvers-2.6.18-1.2798.fc6.gz
grub                          vmlinuz-2.6.18-1.2798.fc6
initrd-2.6.18-1.2798.fc6

boot/grub:
device.map     grub.conf         minix_stage1_5     stage2
e2fs_stage1_5  iso9660_stage1_5  reiserfs_stage1_5  ufs2_stage1_5
fat_stage1_5   jfs_stage1_5      splash.xpm.gz      vstafs_stage1_5
ffs_stage1_5   menu.lst          stage1             xfs_stage1_5

boot/lost+found:

and the contents of /boot on the root partition (/dev/VolGroup00/LogVol00):
boot:
System.map-2.6.24-2.fc9  grub                     vmlinuz-2.6.24-2.fc9
config-2.6.24-2.fc9      initrd-2.6.24-2.fc9.img

boot/grub:
splash.xpm.gz


Version-Release number of selected component (if applicable):
anaconda-11.4.0.28-1

How reproducible:
Only tried once so far; the upgrade takes about an hour.

Steps to Reproduce:
1. Install FC6 using the default partition layout and most package groups.  You
may need at least 10GB of disk space.
2. Boot the FC9 Alpha install DVD and upgrade the existing installation.
3. Reboot after the upgrade is complete.

Actual results:
Booted linux 2.4.18-1.2798.fc6

Expected results:
Should boot linux 2.4.24-2.fc9

Additional info:
I tried manually copying the new kernel image to the /boot partition, adding
/boot back into /etc/fstab, and adding a new entry for linux 2.4.24-2.fc9 to
boot.grub.  The system seemed to start okay, with the exception of the X server,
due to an ABI version mismatch in the kbd driver.  I'll check for a separate bug
report on that.  Also, the kernel-devel package appears to be missing from FC9,
so I can't recompile the VMware tools.
Comment 1 Jeremy Katz 2008-02-24 19:43:23 EST
Was /boot listed in /etc/fstab?
Comment 2 Trevin Beattie 2008-02-24 22:59:44 EST
I assume you mean before I started the upgrade?  Good thing I took snapshots of
the virtual machine before upgrading. ;-)

[trevin@fc9 ~]$ cat /etc/fstab 
/dev/VolGroup00/LogVol00 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0
/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0
Comment 3 Trevin Beattie 2008-03-08 11:24:40 EST
Reproduced the problem again while doing another test run for bug #424720
(upgrading with the 'selinux=0' option).
Comment 4 Trevin Beattie 2008-03-08 15:55:32 EST
I managed to bypass this bug by manually mounting /mnt/sysimage/boot from VT2
while anaconda was checking installed package information for dependencies.  By
this time it had already overwritten /etc/fstab, so I re-added the entry for
/boot as well.

anaconda crashed near the end of the upgrade process, in File
"/usr/lib/booty/bootloaderInfo.py", line 759, in writeGrub.  On reboot, I was
met with the "grub> " CLI prompt.  The grub.conf file had been truncated.  The
good news is that the kernel image was properly upgraded on the boot partition
this time.

I suspect that the reason grub.conf didn't exist (on the wrong filesystem) in my
first attempt is that the upgrade must have crashed that time too, only I didn't
notice it before the virtual machine shut down.
Comment 5 Jeremy Katz 2008-04-08 14:04:50 EDT
I did an upgrade the middle of last week like this without problems :-/  
Comment 6 Jeremy Katz 2008-04-15 22:51:08 EDT
Can you try this again with rawhide or the PR (which should hopefully be
built/go out tomorrow)
Comment 7 Jon Stanley 2008-04-16 13:32:36 EDT
I did FC6->rawhide ~1 day ago and it worked fine.  Closing.
Comment 8 Trevin Beattie 2008-04-18 01:55:33 EDT
I wasn't able to download the PR, but I finally downloaded and tested the beta
release tonight.  The /boot partition was mounted and updated normally.  Problem
solved.

Note You need to log in before you can comment on or make changes to this bug.