Bug 434721 - HTML docs no longer in the git-core package
HTML docs no longer in the git-core package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: git (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Wright
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-24 18:33 EST by Bill Crawford
Modified: 2013-01-10 05:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 08:56:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Crawford 2008-02-24 18:33:51 EST
Description of problem:
HTML documentation has gone astray.

Version-Release number of selected component (if applicable):
1.5.4.1-1.fc8

How reproducible:
Install git, look for the HTML docs

Steps to Reproduce:
1. Install git
2. Look in /usr/share/doc/git-1.5.4.1 for the git.html that used to be there 
in previous versions
3. Be unable to find it
  
Actual results:
Not found

Expected results:
git.html should be there (it was in previous versions)

Additional info:
Looks like the addition of gitweb broke this (the docs are now all in the 
gitweb package due to .spec editing slipup). They were there previously (my 
konqueror history shows file:///usr/share/doc/git-core-1.5.2.2/git.html).

It *might* be worth splitting the docs out into a separate package? Although I 
imagine the last thing you want is *another* subpackage, that would make it 
easier to manage (rather than all these separate %doc lines).
Comment 1 Bill Crawford 2008-02-25 17:49:45 EST
Also please could the stylesheet (docbook-xsl.css) be included? Not that it's 
a particularly good one .. ;o)
Comment 2 James Bowes 2008-03-26 08:56:57 EDT
Fixed up in rawhide as git-1.5.4.4-3 (stylesheet included too). Thanks for
noticing, Bill!
Comment 3 Bill Crawford 2008-03-26 12:55:07 EDT
Hah! Only noticed because I'm a complete git n00b ;o)

Note You need to log in before you can comment on or make changes to this bug.