Bug 434737 - anaconda crash creating encrypted PV
anaconda crash creating encrypted PV
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-02-25 01:21 EST by Michael Hampton
Modified: 2013-01-09 23:35 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-01 17:44:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda traceback (286.61 KB, text/plain)
2008-02-25 01:21 EST, Michael Hampton
no flags Details
Anaconda dump (438.51 KB, text/plain)
2008-03-18 11:49 EDT, Jesse Keating
no flags Details

  None (edit)
Description Michael Hampton 2008-02-25 01:21:14 EST
Description of problem:
Anaconda crashes with a traceback when trying to create an encrypted PV as per
defaults on Fedora 9 Alpha. The traceback indicates that the pvcreate command
failed.

Version-Release number of selected component (if applicable):
anaconda-11.4.0.28

How reproducible:
Always

Steps to Reproduce:
1. Boot Fedora 9 Alpha DVD. 
2. Erase all partitions on disk, accept default partitioning and encryption.
3. Enter encryption passphrase.
  
Actual results:
Anaconda crashes and provides a traceback. The file created is attached.

Expected results:
Anaconda should create the encrypted PV and proceed to the next installation step.

Additional info:
Comment 1 Michael Hampton 2008-02-25 01:21:14 EST
Created attachment 295766 [details]
anaconda traceback
Comment 2 David Lehman 2008-03-13 12:26:37 EDT
I have been unable to reproduce this error. It looks like cryptsetup crashed
while trying to create the LUKS mapping for the PV. Does this still happen for
you with current rawhide trees?
Comment 3 Jesse Keating 2008-03-18 11:48:53 EDT
I am seeing this with today's rawhide (20080318).  My setup is slightly
different in that I'm doing encryption of an LVM PV which is on top of an mdraid
0.  My dump looks similar and I'll attach it.  Can be split into it's own bug if
this is something different than the original posters, but the errors look
generic enough.
Comment 4 Jesse Keating 2008-03-18 11:49:55 EDT
Created attachment 298409 [details]
Anaconda dump

Dump from my install attempt.
Comment 5 Jesse Keating 2008-04-01 17:44:29 EDT
Hrm, I can't see this anymore, and I think we fixed some stuff on the backend
around this.  Closing as rawhide for now, will re-open if seen again.

Note You need to log in before you can comment on or make changes to this bug.