Bug 434757 - Xenoprof doesn't work 32-on-64 dom0
Xenoprof doesn't work 32-on-64 dom0
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
All Linux
low Severity low
: rc
: ---
Assigned To: Markus Armbruster
Martin Jenner
Depends On:
  Show dependency treegraph
Reported: 2008-02-25 05:43 EST by Markus Armbruster
Modified: 2009-01-22 05:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-01-22 05:50:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Markus Armbruster 2008-02-25 05:43:05 EST
Description of problem:
Xenoprof doesn't work with a 32-bit dom0 and a 64-bit HV according to

How reproducible:
I haven't tested this yet.

Steps to Reproduce:
Not known exactly.
Actual results:
Allegedly, the performance counters are not programmed correctly, and no samples
are generated.

Expected results:
Performance counters are programmed just like for a 64-bit dom0.
Comment 1 Chris Lalancette 2009-01-22 05:50:21 EST
I'm going to close this one out; we don't support a 32-bit dom0 with a 64-bit HV, so there doesn't seem to be a lot of reason to fix this.  If you disagree, feel free to re-open.

Chris Lalancette

Note You need to log in before you can comment on or make changes to this bug.