Bug 434763 - F-9 pv_ops xen: update anaconda's xen console handling to use hvc
F-9 pv_ops xen: update anaconda's xen console handling to use hvc
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: PvOpsTracker
  Show dependency treegraph
 
Reported: 2008-02-25 06:06 EST by Mark McLoughlin
Modified: 2008-03-26 11:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 11:40:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2008-02-25 06:06:09 EST
Whatever anaconda knows about Xen's consoles:

  loader2/devices.h:54:    {"xvc0", CHARDEV, 204, 191, 0600, "root", "root"},
  loader2/init.c:598:    char * consoles[] = { "/dev/ttySG0", "/dev/xvc0", NULL };
  loader2/init.c:600:    char * consoles[] = { "/dev/xvc0", NULL };

needs to be updated when we switch to a pv_ops based kernel-xen, because Xen's
console is now available through "hvc"

(Note, not assigning to anaconda-maint-list until we switch rawhide over. Latest
scratch build available from here:

  http://koji.fedoraproject.org/koji/taskinfo?taskID=460974
)
Comment 1 Jeremy Katz 2008-02-25 12:23:25 EST
Made a quick guess at what the right change will be and committed it to git. 
When pvops xen is in rawhide and thus the kernel is pulled into the images, it
can be tested a lot more easily
Comment 2 Mark McLoughlin 2008-03-07 03:11:39 EST
kernel-xen-2.6-2.6.25-0.0.rc4.fc9 is in rawhide now
Comment 3 Mark McLoughlin 2008-03-07 09:37:12 EST
Seems it's not quite there yet

"text mode forced due to serial/virtpconsole"
Comment 4 Jeremy Katz 2008-03-26 11:36:22 EDT
*** Bug 437706 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2008-03-26 11:40:27 EDT
The second half of this is bug 437706 and it has more of hte useful info, so I'm
going to close this one since the basic handling is there and working right.

Note You need to log in before you can comment on or make changes to this bug.