Bug 434775 - ACPI errors on HP xw4600 [NEEDINFO]
ACPI errors on HP xw4600
Status: CLOSED INSUFFICIENT_DATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
All Linux
high Severity high
: rc
: ---
Assigned To: Tony Camuso
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-25 07:35 EST by Lutz Lange
Modified: 2013-10-24 11:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-24 11:09:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tcamuso: needinfo?


Attachments (Terms of Use)
sosreport-xw4600 acpi problems (1.39 MB, application/x-bzip)
2008-02-25 07:35 EST, Lutz Lange
no flags Details
rhel4u5 as sysreport (358.69 KB, application/x-bzip)
2008-02-25 11:30 EST, Lutz Lange
no flags Details

  None (edit)
Description Lutz Lange 2008-02-25 07:35:00 EST
Description of problem:
I did a clean Enterprise 5.1 install :
 - power button did not work
 - suspend left the screen blank
 - hibernate an restart got me a blank screen

So i tried the last available kernel : 2.6.18-83.el5
 - now power button works - but the ACPI ERRORS persist
 - the virtual consoles are not displayed any more (blank screen)
 - hibernate and suspend dont work

Expected results:
 - really need power button and virtual consoles working

Additional info:
i created an sosreport you'll find it attached
Comment 1 Lutz Lange 2008-02-25 07:35:00 EST
Created attachment 295791 [details]
sosreport-xw4600 acpi problems
Comment 2 Brian Maly 2008-02-25 10:51:14 EST
Is the situation any better if "acpi=off" is used at boot?
Comment 3 Brian Maly 2008-02-25 11:02:17 EST
This problem is most often due to a BIOS bug and commonly affects HP XW series
machines. 

The dmidecode output in the sysreport (from Comment #1) is empty. Can you check
to see what the BIOS revision is?

 
Comment 5 Lutz Lange 2008-02-25 11:30:27 EST
Created attachment 295809 [details]
rhel4u5 as sysreport
Comment 6 Lutz Lange 2008-02-25 11:31:49 EST
i did a test with rhel4u5 and the power button worked find. You'll find the
sysreport in comment #5
Comment 7 Lutz Lange 2008-02-25 11:37:46 EST
ok, but there are still ACPI ERRORS on shutdown : 
ACPI-0691: *** Error: acpi_ev_gpe_dispatch: No handler or method fo GPF[3C],
disabling event 
- shutdown hangs

Comment 8 Lutz Lange 2008-02-25 11:40:04 EST
Bios on the xw4600 is v01.03
Comment 9 Lutz Lange 2008-02-26 03:38:40 EST
I did a reinstall of rhel5 and kernel-2.6.18-83. I booted with acpi=off. Virtual
screens are blank - nothing there at all. And hitting the power button will turn
of power to the system imediately - like pulling the cable, which was to be
expected.

Comment 10 Lutz Lange 2008-02-26 04:38:07 EST
I flashed the Bios to v01.07

Still the acpi-problems persist :
 with kernel 2.6.18-53
  - virtual consoles intact
  - power button shows reaction ( gnome asks what to do ) but shows errors
 
 with kernel 2.6.18-83
  - no virtual consoles ( this might be worth a seperate bugzilla )
  - power button shows reaction, but log has ACPI-Errors : ACPI Error
(evgpe-0711): No handler or method for GPE[xx], disabling event 
  - power button - gnome chosen reboot works
  - power button - gnome chosen shutdown works
  - suspend: system wakes up but leaves blank screen 
  - hibernate: (echo disk > /sys/power/state) wakes up (reachable via ssh) but
fails to show anything on screen.
Comment 14 Vincent Deffontaines 2013-02-26 08:49:37 EST
I have just hit the same problem (on Fedora 17) and applying BIOS update 1.34 does not solve the problem.
However, it seems disabling RAID configuration (which seems to be default on that system even if you own one single hard disk) in the BIOS gets ACPI to work properly. This looks like rain dance, but has occured to work for me, and can be a work around for this problem on some configurations. As soon as I disabled RAID, and reinstalled the very same Fedora 17 system, reboots got to work on this computer.
Comment 15 Tony Camuso 2013-08-22 08:04:41 EDT
Does the system install or boot with kernel parameter acpi=off ?
Comment 16 Tony Camuso 2013-10-24 11:09:19 EDT
Have waited 2 months for a reply.

Closing as INSUFFICIENTDATA

The reporter is free to reopen this bug, if he has an answer to the requested information.

Note You need to log in before you can comment on or make changes to this bug.