Bug 434814 - Please build SMBus driver i2c-piix4 as a module
Please build SMBus driver i2c-piix4 as a module
Status: CLOSED DUPLICATE of bug 424541
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Red Hat Kernel Manager
Martin Jenner
Depends On:
Blocks: RHEL4u7_relnotes
  Show dependency treegraph
Reported: 2008-02-25 11:58 EST by Bhavna Sarathy
Modified: 2009-01-20 22:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-26 10:43:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bhavna Sarathy 2008-02-25 11:58:30 EST
+++ This bug was initially created as a clone of Bug #424531 +++

Description of problem:
RHEL5.1 did not build i2c-piix4 into the kernel or as a module,
although the driver patch of AMD SBX00 SMBus has been added into source.
Would you please modify your config file and build i2c-piix4
as a module? So that our customer need not build the kernel source
by themselves if they need the SMBus driver. They only need to load
the driver module.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. # modinfo i2c-piix4 in RHEL5.1
2. check the config file in /boot/

Actual results:
1. No such module i2c-piix4 can be found in RHEL5.1
2. If you check the config file in the /boot/, you will find
that CONFIG_I2C_PIIX4 is not set.

Expected results:
1. i2c-piix4 and the description should be found when run "modinfo i2c-piix4"
2. CONFIG_I2C_PIIX4=m should be found in the config file in /boot/

Additional info:
I need not provide any patch here, what you need do is to re-configure
the config file with "make menuconfig" or some commands else, and select
the CONFIG_I2C_PIIX4 as a module, and provide it in RHEL5.2

-- Additional comment from bnagendr@redhat.com on 2007-12-18 09:00 EST --
Do you need any more information to resolve this?  Let me know what is needed to
move this forward and include it in R5.2. 

-- Additional comment from bnagendr@redhat.com on 2007-12-18 10:39 EST --

I built modules on the latest development kernel tree and it appears that
i2c-piix4 is being built.  I'm not sure if this is a recent addition to the dev.
kernel, but it sounds to me that R5.2 has what you needs.

 [root@bnagendr linux-2.6.18.i386]# find . -name "i2c-piix4*" -print

You can grab the source from this link.


Prarit, please add if you have any more insight.


-- Additional comment from peterm@redhat.com on 2007-12-19 09:29 EST --
CONFIG_I2C_PIIX4 is enabled for x86 builds only.  Nothing has changed in RHEL5
regarding the config option setting.  Does anyone know which archs AMD is
looking to enable the option on?

-- Additional comment from prarit@redhat.com on 2007-12-19 10:23 EST --
Shane, is it possible that you were using x86_64?  RH does not build i2c_piix4
for x86_64.


-- Additional comment from bnagendr@redhat.com on 2007-12-19 11:54 EST --
Posted the patch (config change) to RHML as discussed with peterm.   Please
provide the necessary BZ ACKs.  


-- Additional comment from shane.huang@amd.com on 2007-12-19 20:46 EST --
I checked the kernel config of RHEL5.1 and 2.6.18-61.el5 again, confirmed that
the CONFIG_I2C_PIIX4 has been built as module in x86. But kernels for x86_64
has not built it.

Can you build it too under x86_64? Is there any problem which make you disable 


-- Additional comment from dzickus@redhat.com on 2008-01-10 15:40 EST --
in 2.6.18-66.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5

-- Additional comment from mgahagan@redhat.com on 2008-02-05 14:46 EST --
confirmed in the -77 kernel that CONFIG_I2C_PIIX4 is set to module on i386,
disabled altogether for x86_64.

-- Additional comment from mgahagan@redhat.com on 2008-02-06 11:57 EST --
fixed in the -78.el5 kernel for x86_64:

[root@test177 ~]# grep -i piix4 /boot/config-2.6.18-78.el5
[root@test177 ~]# rpm -q kernel-2.6.18-78.el5 | head
[root@test177 ~]#
[root@test177 ~]# rpm -q --changelog kernel-2.6.18-78.el5 | head
* Tue Feb 05 2008 Don Zickus <dzickus@redhat.com> [2.6.18-78.el5]
modinfo i2c-piix4
filename:       /lib/modules/2.6.18-78.el5/kernel/drivers/i2c/busses/i2c-piix4.ko
license:        GPL
description:    PIIX4 SMBus driver
author:         Frodo Looijaard <frodol@dds.nl> and Philip Edelbrock
srcversion:     4F470740B13E55AA2D71E48
alias:          pci:v00001055d00009463sv*sd*bc*sc*i*
alias:          pci:v00008086d0000719Bsv*sd*bc*sc*i*
alias:          pci:v00001166d00000205sv*sd*bc*sc*i*
alias:          pci:v00001166d00000203sv*sd*bc*sc*i*
alias:          pci:v00001166d00000201sv*sd*bc*sc*i*
alias:          pci:v00001166d00000200sv*sd*bc*sc*i*
alias:          pci:v00001002d00004385sv*sd*bc*sc*i*
alias:          pci:v00001002d00004372sv*sd*bc*sc*i*
alias:          pci:v00001002d00004363sv*sd*bc*sc*i*
alias:          pci:v00001002d00004353sv*sd*bc*sc*i*
alias:          pci:v00008086d00007113sv*sd*bc*sc*i*
depends:        i2c-core
vermagic:       2.6.18-78.el5 SMP mod_unload gcc-4.1
parm:           force:Forcibly enable the PIIX4. DANGEROUS! (int)
parm:           force_addr:Forcibly enable the PIIX4 at the given address.

-- Additional comment from ddomingo@redhat.com on 2008-02-06 20:58 EST --
added to RHEL5.2 release notes under "Kernel-Related Updates":

i2c-piix4 kernel module is now enabled to support AMD SBX00 SMBus.

please advise if any further revisions are required. thanks!

-- Additional comment from shane.huang@amd.com on 2008-02-12 21:33 EST --
Hi Mike and Don:

Can you also enable it in the kernel for RHEL4.7?
The bugzilla number is: 424541

Comment 1 Bhavna Sarathy 2008-02-26 10:43:31 EST

*** This bug has been marked as a duplicate of 424541 ***
Comment 2 Don Domingo 2008-06-02 19:17:34 EDT

the RHEL4.7 release notes deadline is on June 17, 2008 (Tuesday). they will
undergo a final proofread before being dropped to translation, at which point no
further additions or revisions will be entertained.

a mockup of the RHEL4.7 release notes can be viewed here:

please use the aforementioned link to verify if your bugzilla is already in the
release notes (if it needs to be). each item in the release notes contains a
link to its original bug; as such, you can search through the release notes by
bug number.


Note You need to log in before you can comment on or make changes to this bug.