Bug 434834 - nm-applet crashes leaving blank applet when another instance already running
nm-applet crashes leaving blank applet when another instance already running
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-25 14:01 EST by Gerald Cox
Modified: 2008-11-22 11:56 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-22 11:56:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Cox 2008-02-25 14:01:13 EST
Description of problem:
knetworkmanager does not launch - application hangs.

Version-Release number of selected component (if applicable):
Version used with F9 is:  knetworkmanager.x86_64 0:0.2-0.7.fc8

How reproducible:
Launch ketnetworkmanager application


Steps to Reproduce:
1.  Launch knetworkmanager application
2.
3.
  
Actual results:
Application hangs

Expected results:
Successful launch.

Additional info:

This appears to have been mentioned during F8 development:

https://bugzilla.redhat.com/show_bug.cgi?id=298991

and from the comments it appears that the fix is now available and has been
integrated into OpenSUSE.
Comment 1 Rex Dieter 2008-02-25 14:31:42 EST
Be aware, knetworkmanger is only a fake front end to NetworkManager-gnome (as 
noted in bug #298991).

That said, when you say
"Launch knetworkmanager" how exactly are you doing that?

"Application hangs", clearly nothing runs (else you wouldn't have filed this 
report), but what makes you think it (nm-applet in this case) hangs?
Comment 2 Rex Dieter 2008-02-25 14:33:23 EST
Fwiw (if it wasn't clear), running knetworkmanager from a command-line or via 
menus worksforme (and launches nm-applet).
Comment 3 Gerald Cox 2008-02-25 14:48:39 EST
To launch the application, I:

Press the KMENU ICON
Press SYSTEM ICON
Press Network Manager (KNetworkManager)ICON

When I do this, an white box appears in the applet area.  When I select this
box, nothing happens.  NetworkManager is already running.  If I stop
NetworkManager, same behavior.  The GNOME NM-applet is working fine under KDE4.

I am aware that the current knetworkmanager (knetworkmanager.x86_64
0:0.2-07.fc8) is a "fake" front end put in place as part of bug 298991 - which I
read and referenced in this bug report.  

The last comment in that bug report states that OpenSUSE is now shipping a fix
to this problem, which would restore knetworkmanager instead of using the "fake"
front-end.  I opened this report since I wasn't sure if 298991 was no longer
active since it was originally created for F8 - and now we have moved on to F9.

F9 should be using the new knetworkmanager instead of the "fake" front-end used
as an interim step for F8.   

Comment 4 Rex Dieter 2008-02-25 15:10:50 EST
We purposely haven't enabled real knetworkmanager in rawhide yet, because, well,
how to say this nicely... it's not very usable yet. :)  See also:
http://ausil.us/blog/f9-knm
Otoh, this *is* rawhide afterall, where testing, broken-ness isn't out of the
ordinary.  Maybe it wouldn't hurt to get more exposure.

That said, the "white box" you mention is nm-applet.  If it isn't working, I'd
suggest filing a bug against it (NetworkManager-gnome), or dup/reassign this
report, whatever floats your boat.

In the meantime, and before you do that, make sure your box is up-to-date
rawhide-wise.  Lot's of updates/fixes since F9-alpha release.
Comment 5 Gerald Cox 2008-02-25 15:30:31 EST
Hey Rex, 
Sorry, this is getting confusing.  The GNOME network applet works fine with KDE4
in F9 Alpha.  I get the white box when I try to launch knetworkmanager.  When I
do this I get the white box IN ADDITION TO the GNOME network applet.  In
hindsight I think it would have been better to just remove knetworkmanager or
leave it be in whatever state it was in than to do the "fake" front-end.  It is
really confusing. My service is up-to-date with what is currently in rawhide.  I
reviewed the f9-knm website - and think you all should push the new version to
rawhide - couldn't be any worse than what is out there now... and you'd get some
feedback on how it is performing - you're right; rawhide is for testing.... ;-)
Comment 6 Rex Dieter 2008-02-25 15:50:43 EST
ok, so the bug here really is "launching nm-applet in KDE4 leaves a white box in
system tray". :)
Comment 7 Dennis Gilmore 2008-02-25 16:30:49 EST
I have seen this.  the problem is nm-applet crashes if something else owns the
NetworkManager client dbus side and leaves a blank applet  in this instance
nm-applet is running already it also happens when knetworkmanger starts before
nm-applet

you get the following traceback in konsole if you start it there

** (nm-applet:16567): WARNING **: <WARN>  applet_dbus_manager_start_service():
Could not acquire the NetworkManagerUserSettings service as it is already
taken.  Return: 3


(nm-applet:16567): GLib-CRITICAL **: g_hash_table_destroy: assertion
`hash_table != NULL' failed

(nm-applet:16567): GLib-GObject-CRITICAL **: g_object_unref: assertion
`G_IS_OBJECT (object)' failed

(nm-applet:16567): GLib-GObject-CRITICAL **: g_object_unref: assertion
`G_IS_OBJECT (object)' failed

Reassigning to NetworkManager 
Comment 8 Kevin Kofler 2008-02-25 16:59:29 EST
Fixing summary to make it clear what is really happening.
Comment 9 Gerald Cox 2008-02-25 17:28:59 EST
I will open another bug report regarding knetworkmanager.
Comment 10 Orion Poplawski 2008-03-14 22:19:47 EDT
So, is it all possible to run nm-applet under KDE?
Comment 11 Orion Poplawski 2008-03-14 22:27:22 EDT
Fresh install of (KDE focused) rawhide 20080314.  No knetworkmanager any more. 
nm-applet is not running.  Go to run it and:

$ nm-applet

** (nm-applet:4126): WARNING **: <WARN>  applet_dbus_manager_start_service():
Could not acquire the NetworkManagerUserSettings service.
  Message: 'Connection ":1.222" is not allowed to own the service
"org.freedesktop.NetworkManagerUserSettings" due to security policies in the
configuration file'


(nm-applet:4126): GLib-CRITICAL **: g_hash_table_destroy: assertion `hash_table
!= NULL' failed

(nm-applet:4126): GLib-GObject-CRITICAL **: g_object_unref: assertion
`G_IS_OBJECT (object)' failed

(nm-applet:4126): GLib-GObject-CRITICAL **: g_object_unref: assertion
`G_IS_OBJECT (object)' failed

Then I have the blank box in the tray.  So I have no way of configure NM
wireless connections.
Comment 12 Rex Dieter 2008-03-14 22:32:57 EDT
Re: comment #10
Of course, we've been doing precisely that in kde-live spin since f8.   The "is
not allowed to own the service" message you're seeing (comment #11) looks
ominous, indicative of other problems.   I'd suggest filing a separate bug/issue
wrt this.

Shrug, works nicely on rawhide for me.  ??

Re: comment #5
> In hindsight I think it would have been better to just remove knetworkmanager 

Fwiw, for f9 (and likely f8 soon), we've done just that.
Comment 13 Orion Poplawski 2008-03-27 17:28:51 EDT
This problem appears to have gone away for me.
Comment 14 Bug Zapper 2008-05-14 01:38:14 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Gerald Cox 2008-11-22 11:56:14 EST
I believe that this can be closed now.  
Knetworkmanager is alive and well in F10 ;-)

Note You need to log in before you can comment on or make changes to this bug.