Bug 434845 - launching totem from the gnome mini commander applet does not work
launching totem from the gnome mini commander applet does not work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-02-25 15:11 EST by Nicolas Mailhot
Modified: 2008-03-05 11:28 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-05 11:28:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2008-02-25 15:11:36 EST
Description of problem:

If I type totem <enter> in the gnome mini commander applet a totem-sized window
with a blank popup flashes open then dies

Starting totem from gnome-terminal or the main menu OTOH works

Please fix this regression - I had a nice totem /dev/video0 mini-commander
shortcut I used a lot before

Version-Release number of selected component (if applicable):

totem-2.21.93-2.fc9.x86_64

How reproducible:

Always
Comment 1 Bastien Nocera 2008-02-26 06:12:31 EST
Probably a crash or an assertion. Check ~/.xsession-errors to see if there are
warnings caused by totem. Also make sure to use liboil-0.3.13-2.fc9, -1.fc9 had
a known crasher.
Comment 2 Nicolas Mailhot 2008-02-26 14:18:24 EST
(In reply to comment #1)
> Probably a crash or an assertion. Check ~/.xsession-errors to see if there are
> warnings caused by totem. 

Nothing there

> Also make sure to use liboil-0.3.13-2.fc9, -1.fc9 had
> a known crasher.

My rawhide is up-to-date :p
As I wrote totem only commits suicide when launched from mini-commander
Comment 3 Matthias Clasen 2008-03-04 23:37:18 EST
Here is what totem reports before it commits suicide:

No value set for `/apps/totem/backend'
/usr/bin/totem: line 50: exec: totem-: not found
Comment 4 Matthias Clasen 2008-03-04 23:41:47 EST
Actually, it reports the same when started from a terminal...
Comment 5 Bastien Nocera 2008-03-05 07:21:07 EST
(In reply to comment #3)
> Here is what totem reports before it commits suicide:
> 
> No value set for `/apps/totem/backend'
> /usr/bin/totem: line 50: exec: totem-: not found

That'd be with 2.21.95. The package was completely broken. Nicolas, could you
test with 2.23.0. And try to get some debugging information, I really can't do
much without anything to work from.
Comment 6 Nicolas Mailhot 2008-03-05 08:34:32 EST
I can't get debugging information when no error or warning ends up in the logs.
The test case is really simple (launch totem from the mini-commander applet), so
unless it works on a rawhide box located near you, why don't you look at it
directly?
Comment 7 Matthias Clasen 2008-03-05 11:28:35 EST
Works fine here with 2.23.0. So I assume it is fixed.
Please reopen if you still see the issue with that version.

Note You need to log in before you can comment on or make changes to this bug.