Bug 434863 - upstart removes /sbin/pidof
Summary: upstart removes /sbin/pidof
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: upstart
TreeView+ depends on / blocked
 
Reported: 2008-02-25 21:37 UTC by Terje Røsten
Modified: 2014-03-17 03:12 UTC (History)
2 users (show)

Fixed In Version: 8.64-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-26 21:07:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Terje Røsten 2008-02-25 21:37:09 UTC
Description of problem:

I installed nottings upstart.repo and installed upstart and
event-compat-sysv. Of course this removes sysvinit and then
the /sbin/pidof binary, which upstart don't provide.

In rebooting /etc/rc.d/rc.sysinit is unhappy as

$ grep pidof rc.sysinit
nashpid=$(pidof nash 2>/dev/null)
        pid=$(/sbin/pidof getkey)

upstart or another package should provide /sbin/pidof ?

Later I saw nash-<something-I-forgot> taking 100% CPU.

Another broken thing is my keyboard going from norwegian to english, gconfd
related?

Comment 1 Casey Dahlin 2008-02-25 21:43:55 UTC
Pidof should be provided by the sysvinit-tools package, which must not be
getting pulled in by event-compat-sysv (should actually be pulled by initscripts).

Rebuilding initscripts and some other packages might cause them to autodetect
these deps correctly.

For now try yum install sysvinit-tools and see if that fixes it.

You keyboard is almost certainly unrelated. Upstart doesn't touch gconfd.
Nonetheless keep us posted on it.

Comment 2 Terje Røsten 2008-02-25 21:58:51 UTC
I just grabbed /sbin/pidof from old sysvinit and that worked.

Something is funky with gconfd, after gnome login I get 

Message did not receive a reply (timeout by message bus)

Another thing:

I have mingetty running, ps -ef | grep mingetty 

root      1976     1  0 22:43 tty4     00:00:00 /sbin/mingetty tty4
root      1978     1  0 22:43 tty5     00:00:00 /sbin/mingetty tty5
root      1982     1  0 22:43 tty2     00:00:00 /sbin/mingetty tty2
root      1985     1  0 22:43 tty3     00:00:00 /sbin/mingetty tty3
root      1989     1  0 22:43 tty1     00:00:00 /sbin/mingetty tty1
root      1992     1  0 22:43 tty6     00:00:00 /sbin/mingetty tty6

however ctrl-alt-f1 etc dont work.



Comment 3 Casey Dahlin 2008-02-25 22:02:53 UTC
hmm, the ttys work for me.

Upstart is a client of the message bus, but it shouldn't be causing that kind of
issue. Did you pull anything else when you updated.


On topic: Packages which should now require sysvinit-tools:

autofs-5.0.3-5.i386
cpuspeed-1.2.1-5.fc9.i386
dnsmasq-2.41-0.8.fc9.i386
gpm-1.20.1-90.fc9.i386
initscripts-8.63-1.i386
iptables-1.3.8-6.fc9.i386
iptables-ipv6-1.3.8-6.fc9.i386
nfs-utils-1.1.1-4.fc9.i386


Comment 4 Bill Nottingham 2008-02-25 22:12:06 UTC
(In reply to comment #2)

> Something is funky with gconfd, after gnome login I get 
> 
> Message did not receive a reply (timeout by message bus)
> 
> Another thing:
> 
> I have mingetty running, ps -ef | grep mingetty 
> 
> root      1976     1  0 22:43 tty4     00:00:00 /sbin/mingetty tty4
> root      1978     1  0 22:43 tty5     00:00:00 /sbin/mingetty tty5
> root      1982     1  0 22:43 tty2     00:00:00 /sbin/mingetty tty2
> root      1985     1  0 22:43 tty3     00:00:00 /sbin/mingetty tty3
> root      1989     1  0 22:43 tty1     00:00:00 /sbin/mingetty tty1
> root      1992     1  0 22:43 tty6     00:00:00 /sbin/mingetty tty6
> 
> however ctrl-alt-f1 etc dont work.

These are almost certainly unrelated. CTRL-ALT-F1 not working is a known issue
with rawhide X.


Comment 5 Terje Røsten 2008-02-25 22:30:20 UTC
OK, thanks notting. GDM seems to be in some strange shape too, related?

I tried:

/etc/init.d/messagebus stop

and X went down! Not so clever to do that, I guess? 
However my ttys was back after that.

I also have pulseaudio and console-policy-kit crashing, however that's not new.

All in all, everything is back to normal after adding the sysvinit-tools
package. Boot time is about equal, shutdown is faster with upstart.




Comment 6 Bill Nottingham 2008-02-26 21:07:48 UTC
This was fixed in initscripts-8.63-2/initscripts-8.64-1.


Note You need to log in before you can comment on or make changes to this bug.