Bug 434874 - USB printer is no longer detected
USB printer is no longer detected
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-25 17:34 EST by Ed Friedman
Modified: 2008-02-26 13:45 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-26 13:45:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ed Friedman 2008-02-25 17:34:14 EST
Description of problem:
system-config-printer no longer sees USB printer

Version-Release number of selected component (if applicable):
system-config-printer-0.7.74.10-3.fc8

How reproducible:
Always

Steps to Reproduce:
1.Start with 32 bit PC with almost all packages installed, all updates current,
and SELinux turned off.
2.Start system-config-printer with USB printer plugged in.
3.Click on "New Printer".
  
Actual results:
No USB printers are shown

Expected results:
The USB printer shown should show up

Additional info:

dmesg shows:
usblp0: USB Bidirectional printer dev 2 if 0 alt 0 proto 2 vid 0x043D pid 0x0070
usbcore: registered new interface driver usblp

lsusb (which sees the printer) gives:
Bus 001 Device 001: ID 0000:0000  
Bus 005 Device 001: ID 0000:0000  
Bus 004 Device 001: ID 0000:0000  
Bus 003 Device 002: ID 043d:0070 Lexmark International, Inc. 
Bus 003 Device 001: ID 0000:0000  
Bus 002 Device 001: ID 0000:0000  

hp-probe -busb gives:
warning: No devices found on the 'usb' bus. If this isn't the result you are
expecting,
warning: check to make sure your devices are properly connected and powered on.

Everything was working properly until a few weeks ago.  I have tried backing out
to installation CD rpm's for system-config-printer, udev, cups, cups-libs, but
the problem still persists.  I have also tried booting to a previous kernel, but
that also did nothing to fix this problem.  I suspect that the problem may be
due to an rpm other than system-config-printer, but I have no idea which rpm
that would be.
Comment 1 Tim Waugh 2008-02-26 06:21:48 EST
In the 'lsusb' output above, bus 003 device 002 corresponds to the printer. 
Please connect the printer, switch it on, and note the bus and device numbers
for the printer now.  Then run this command, with the correct numbers substituted:

getfacl /dev/bus/usb/003/002

What does it say?
Comment 2 Ed Friedman 2008-02-26 13:18:17 EST
You can delete this bug report.  Today the printer is showing up in
system-config-printer as an option under New Printer and it is printing properly.

Note You need to log in before you can comment on or make changes to this bug.