Bug 434885 - -fpeephole2 caused "internal compiler error: in final_scan_insn, at final.c:2514"
-fpeephole2 caused "internal compiler error: in final_scan_insn, at final.c:2...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gcc4 (Show other bugs)
4
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-25 19:08 EST by Haiping Zhao
Modified: 2008-03-11 05:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-11 05:47:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
preprocessed source (45.05 KB, application/octet-stream)
2008-02-25 19:08 EST, Haiping Zhao
no flags Details

  None (edit)
Description Haiping Zhao 2008-02-25 19:08:16 EST
Compiling this file:

#include <stdio.h>
#include <stdlib.h>
#include <sys/time.h>

int main() {
  struct timeval now;
  return now.tv_usec % 15;
}

with this command,

g++ -c -fpeephole2 test.cpp


The problem goes away if "now.tv_usec" is casted to "int" a 32-bit number. So,
it's related to the fact it's a 64-bit integer.
Comment 1 Haiping Zhao 2008-02-25 19:08:16 EST
Created attachment 295862 [details]
preprocessed source
Comment 2 petrosyan 2008-02-26 00:07:42 EST
Haiping,
Fedora Core 4, 5, and 6 are not maintained anymore. Can you reproduce this bug
on Fedora 7 or Fedora 8? I can not reproduce this on Fedora 8.
Comment 3 Jakub Jelinek 2008-03-11 05:47:25 EDT
Can't reproduce with current gcc 3.4.x, 4.0.x, 4.1.x, 4.2.x nor 4.3.0.

Note You need to log in before you can comment on or make changes to this bug.