Bug 434920 - Openoffice rpm does not have required depency for libicu
Openoffice rpm does not have required depency for libicu
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-26 04:44 EST by Jani Mikkonen
Modified: 2008-02-26 05:19 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-26 05:04:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jani Mikkonen 2008-02-26 04:44:46 EST
Description of problem:

Openoffice rpm packages do not have depency  for libicu which is mandatory to
even start the application.

Version-Release number of selected component (if applicable):

openoffice.org-calc-2.3.0-6.11.fc8
openoffice.org-writer-2.3.0-6.11.fc8
openoffice.org-core-2.3.0-6.11.fc8

Fedora 8 with latest updates.



How reproducible:

Fresh and minimal installation of FC8 without openoffice or any subcomponents
installed.

Steps to Reproduce:
1. Install openoffice.org-core, openoffice.org-writer & openoffice.org-calc via
 pirut
  
Actual results: Launching of oowriter fails, shell output:

[jani@jani-desktop ~]$ oowriter
/usr/lib/openoffice.org/program/swriter.bin: error while loading shared
libraries: libicui18n.so.38: cannot open shared object file: No such file or
directory


Expected results:
Openoffice should start


Additional info:

Installing latest libicu will solve this error.
Comment 1 Caolan McNamara 2008-02-26 05:04:10 EST
It does have the correct requires, whatever went wrong for you is not due to a
missing require, but perhaps e.g. due to some *other* bogus icu providing libraries.

rpm -q --requires openoffice.org-core|grep icu
libicui18n.so.38
libicule.so.38
libicuuc.so.38

what does e.g. rpm -q --whatprovides libicui18n.so.38 say ?
Comment 2 Jani Mikkonen 2008-02-26 05:19:49 EST
[jani@jani-desktop ~]$ rpm -q --whatprovides libicui18n.so.38 
libicu-3.8-5.fc8
[jani@jani-desktop ~]$ 

The problem might be in pirut? As i actually remember now that i did not choose
openoffice.org-core, but only writer and calc and core package was show in added
depencies dialog and then i installed libicu manually after i noticed that
oowriter/calc didnt start..


Note You need to log in before you can comment on or make changes to this bug.